Removing Disk From Array v6.8.3


3 posts in this topic Last Reply

Recommended Posts

Hello, thanks for reading into my issue.

 

I created this post to figure out how to remove the "not installed" error in my array.

 

I removed the 500gb SSD that was added to the array to use in unassigned devices. I placed this disk in the array by mistake. It is not supposed to be there.

Now, in the array, I have a disk 6 error of "not installed" I would like to know how to remove this and get my array back to normal.

 

Please let me know if you need any more information and I will provide it.

image.thumb.png.a78698d746ed85a5d8e06350fe739e05.png

 

Any and all help is appreciated.

-Thanks

Link to post
  • 4 months later...

Sorry if I'm using this thread but I got a follow up question.

So I only had one disk in my array without parity. I added second one (because it was smaller) without parity. Moved all the files onto disk 2.
I want to remove disk 1 and make it the parity drive.

I'm following this :

Quote

Procedure

Make sure that the drive or drives you are removing have been removed from any inclusions or exclusions for all shares, including in the global share settings. Shares should be changed from the default of "All" to "Include". This include list should contain only the drives that will be retained.

Make sure you have a copy of your array assignments, especially the parity drive. You may need this list if the "Retain current configuration" option doesn't work correctly

Stop the array (if it is started)

Go to Tools then New Config

Click on the Retain current configuration box (says None at first), click on the box for All, then click on close

Click on the box for Yes I want to do this, then click Apply then Done

Return to the Main page, and check all assignments. If any are missing, correct them. Unassign the drive(s) you are removing. Double check all of the assignments, especially the parity drive(s)!

Do not click the check box for Parity is already valid; make sure it is NOT checked; parity is not valid now and won't be until the parity build completes

Start the array to commit the changes; system is usable now, but it will take a long time rebuilding parity


So I unnassign Disk 1.
Assign it to Parity .

Do I have to move Disk 2 to Disk 1? Unnassigning Disk 2 and then assigning it at Disk 1, or will unraid do that itself?

Thanks.



Edit:
Never mind. I just YOLOed it.

Turns out you don't need to change the position. It looks funny having a Parity and a Disk 2 though:

909145732_Screenshot(36).png.e437d3c1baa7dfcfe61aa81c4584c943.png

Edited by Heciruam
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.