(Solved) Power failure, now 2x red X's


Recommended Posts

Hi Everyone, Had a power failure, after my Tower3 was powered up, I have 2x drives with a red X.

My other 2x Towers had no issues.

I have been rebuilding my workshop, so the UPS was not protecting the Towers unfortunately. 


Both 8Tb drives have no data, They are about 4 months old approx.

What is the next step to take?

Last parity check was about 30 days ago, added lots of data to other disks, but not 14 and 15 which have the red X's.


Appreciate any advice and help.




Link to comment

Since you have 2 parity disks one option is to rebuild the 2 disabled drives on top of themselves.


however if you are sure they had no data (you can check by looking at the emulated drives if they mount OK) then I would

  • use Tools -> New Config with the option to keep all current assignments
  • return to the Main tab and tick the “parity is Valid” option
  • Start the array and check all other disks look fine
  • run a file system check on the disks that had a red ‘x’ to see if there are any problems at that level
  • run a correcting parity check to get parity back in sync with the array.   Since there were 2 drives disabled I would expect some corrections, but not a vast number.
Link to comment

Thanks itimpi,

I followed your steps, steps 1, 2 and 3 no worries.

Step 4, went into maintenance mode, did the file system check, that ran through. this is from disk 14


Phase 1 - find and verify superblock... Phase 2 - using internal log - zero log... - scan filesystem freespace and inode maps... sb_fdblocks 1939163355, counted 1952984849 - found root inode chunk Phase 3 - for each AG... - scan (but don't clear) agi unlinked lists... - process known inodes and perform inode discovery... - agno = 0 - agno = 1 - agno = 2 - agno = 3 - agno = 4 - agno = 5 - agno = 6 - agno = 7 - process newly discovered inodes... Phase 4 - check for duplicate blocks... - setting up duplicate extent list... - check for inodes claiming duplicate blocks... - agno = 0 - agno = 1 - agno = 2 - agno = 3 - agno = 4 - agno = 7 - agno = 6 - agno = 5 No modify flag set, skipping phase 5 Phase 6 - check inode connectivity... - traversing filesystem ... - traversal finished ... - moving disconnected inodes to lost+found ... Phase 7 - verify link counts... No modify flag set, skipping filesystem flush and exiting.


I could not start correcting parity check, only a Check will start Read-Check of all array disks.


Not sure what to do now,


Much appreciated.

Link to comment

Is any disk showing as disabled (has a red ‘x’)?   It should not after using New Config unless a subsequent write to a drive has failed, but the fact you cannot do a parity check indicates this may have happened.  The best next step may depend on your answer.


the file system check output on disk14 indicates there is some sort of file system level corruption.    You need to rerun the check without the -n option for any fix to take place.


probably worth posting new diagnostics so we can see the state of your system.


Link to comment
1 hour ago, HK-Steve said:

Disk 14 and 15 are still red X after the New Config

Am 40% through the Read-Check


Thanks for looking.



tower3-diagnostics-20201012-1635.zip 170.39 kB · 0 downloads

New Config clears the red ‘x’ status, so the fact that the drives are still showing as disabled is worrying as it means they were disabled again after doing the New Config.   Your syslog is full of read errors on those two drives so they may genuinely have a problem.   I would carefully check the power and SATA cabling in case that is the cause of the problem.


I would suggest that at this point you run an extended SMART test on both drives and post new diagnostics after doing so.

  • Like 1
Link to comment

Finished the Read-Check with no errors.


Here is the Extended Smart Test for Disk 14.

Disk 15 would not go past 10% after 10mins, so I stopped the test. So no report for Disk 15.

Just powered down and checked the sata and power connectors.

Found no problems other than Disk 14 and 15 were very old drives, Seagate Enterprise Capacity v5 Hard drive from 2015.

So I removed them from the array. New Config, set all the disks individually as I wrote them down.
Now doing a Parity rebuild.


Will buy some new 8Tb drives and install next week.


Much appreciated the help itimpi, You have helped me learn a little more about UnRaid.


Link to comment
  • HK-Steve changed the title to (Solved) Power failure, now 2x red X's

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.