[Unraid 6.8.3] Docker Monitoring Using Zabbix Docker Container


Recommended Posts

Hey guys,


i am trying to monitor Unraid docker using Zabbix agent. My Zabbix cannot fetch data from docker engine and I am 100% assured that this is permission issue.


I've mounted all necessary volumes to the container:







When i run this command inside docker 

ls -l /var/run/docker.sock

i get:

srw-rw---- 1 root 281 0 Oct 17 19:51 /var/run/docker.sock


When i run same command in unraid cli i get this:

srw-rw---- 1 root docker 0 Oct 17 19:51 /var/run/docker.sock=


I am not 100% sure if adding PGID=0 and PUID=0 has done any changes.


What I know for sure is that zabbix is accessing docker as user zabbix, so i created user zabbix and then added zabbix user to the docker group using this command:

gpasswd -a zabbix docker


But no luck at all. Can someone help please?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.