Jump to content
Sign in to follow this  
oursondechine

Debian VM FS is read only after reboot

5 posts in this topic Last Reply

Recommended Posts

Hello all, today after a reboot my debian VM had some weird behaviour after looking into it it appears even as root i cannot touch a file in /.

 

`touch: cannot touch '/test': Read-only file system`

 

I created a new VM and after trying to reinstall my services, I ended up with the same error; I don't know if I have a problem with my array or if I'm doing something wrong while installing my  services. Here is the install script for those services in case it can help.

 

Also here the systemctl output on the VM

 

What I have tried so far:

- Rebooting the VM and the UNRAID

- Starting the array in maintenance mode to check my drives; nothing look wrong. Here are one of the output (all almost the same)

- Checked the forum for same problem but without much success

 

I'm lost and don't know what to look for now. Could anyone give me so directions to look into ?

 

Share this post


Link to post

Please post the diagnostics: Tools -> Diagnostics

Share this post


Link to post

Everything looks fine to me on the Unraid side, so likely a VM issue, moving this to the VM section to see if anyone else can help.

Share this post


Link to post

Ok, thank you. In addition i can say that since aproximately the same moment my VM start acting weird my windows PC (non VM; actual PC) have trouble connecting to the array via the windows network explorer; I have to explicitly mount every share as an network drive. I have seen people say it's due to Win 10 network explorer being garbage but i had no problem for over 6 month prior to that.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this