Protonmail Bridge via docker, network issues


BKS

Recommended Posts

I'd like to run protonmail bridge as a docker container on my unraid 6.8.3 box. Nothing is available in CA, so I was able to load a container from dockerhub (currently using shenxn/protonmail-bridge). It loads successfully and I'm able to spin up the protonmail-bridge application, but having trouble with getting network connections to work after that.

My goals are to have the IMAP and SMTP ports via that application open to both network clients as well as clients connected through a "remote tunnel" on wireguard. I've tried all sorts of variations of the networking configurations in VPN settings as well as docker container (bridge, host, custom) but I haven't been successful. Any tips? This is what I'm currently working with:

 

wg.jpg

container.jpg

Link to comment

An update: If I set the network type for the container to custom / br0 and give it a fixed IP, I can connect to the bridge as expected from within the LAN. However, when I try the same thing from a client connected through wireguard, it does not work. When I ping the docker's local IP address from the remote wireguard client, I get destination host unreachable.


Could this be solved with a static route? VLAN?

Link to comment
44 minutes ago, Squid said:

AFAIK, you need to in the router supply a route back to the server to communicate with containers that are on a separate IP.

I don't necessarily need a separate IP. That's just the only way I've gotten it working. It seems like I should be able to enable bridge mode and from the client connect the unraid server's IP, right?

Link to comment
  • 5 weeks later...
21 hours ago, BKS said:


Yes I did, but the only way I was successful was using the host networking interface setting.

You're running the bridge in CLI mode right? I never had an issue with the docker itself having an internet connection.


 

I literally just downloaded the docker from CA and left most of the launch details as it was. Any chance you could do a step by step?? I dont need it to work for clients on a vpn or anything... just a working container would be nice! XD

 

It does say CLI mode in the logs

Edited by tazire
Link to comment
2 hours ago, tazire said:

I literally just downloaded the docker from CA and left most of the launch details as it was. Any chance you could do a step by step?? I dont need it to work for clients on a vpn or anything... just a working container would be nice! XD

 

It does say CLI mode in the logs

1. Enable dockerhub search results in CA

2. search for protonmail bridge; install the version by shenxn

3. Try the following network settings: Network type: Host, imap: 1143, smtp: 1025.

4. Open docker container in console mode

5. Open protonmail bridge in CLI mode by running "protonmail-bridge --cli"

6. Authenticate with "login" command, follow prompts.

7. Copy those credentials into your mail client, replacing the 127.0.0.1 IP address with that of your unraid server.

Link to comment

Ah.... that cli command is what i was missing.... if you try login without the command it doesnt asked for the 2FA code and was giving me a login failed everytime!!! thanks very much for the help. Up and running now. 

 

EDIT

Unfortunately it still doesnt work very well for me at all. I can close the console after i login or i just cant get the login in details anymore... login just wont work after than initial login. restarting the container has a similar effect. Only thing i seem to be able to do is edit the docker and start fresh with it.... And then on top of all this no matter what i try i just cant get anything on my network to use the bridge. I think the fact i get this issue every time i start the docker might show there is some underlying issue with my container. Think im going to give up on this again for now. Thanks again for the help though.  

 

Edited by tazire
Link to comment
  • 4 months later...

Yes I did and have it running atm. Its not without its issues though. In my experience I could only access the CLI on first install so I needed to get everything setup the first time. I had to get it setup in multi inbox mode and save all the login details at this point. I have no way to access the CLI after this. I cant change any details or settings but its still running and working just fine other than that. 

Link to comment
  • 1 month later...
  • 9 months later...
On 11/24/2020 at 2:48 PM, BKS said:

5. Open protonmail bridge in CLI mode by running "protonmail-bridge --cli"

@BKS, what exactly do you mean by this? If you're interacting with protonmail-bridge using the command line, aren't you using the cli? The reason I ask is because when I type in "protonmail-bridge --cli" nothing happens. I then type "login" and keep getting a "login incorrect" error.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.