what causes a share or whole array i guess to go read only through windows


comet424

16 posts in this topic Last Reply

Recommended Posts

i use a share for all my downloads from windows to download to backups etc

and i wasnt able to to make directories etc..  also had a glitch last night audio files play back..

 

so today i couldnt write..  its likes share has gone read only.. a reboot didnt help...  but i did run the docker safe  and seems to fixed it.. also i running the new permissions  as i not sure realyl which one to run to give all access to all the files.. wouldnt even know how u could setup everyhting is read only unless a certain account logs in an then its full access read write..

 

but is it good to have a daily  permission fix on entire array..  what could be causing this issue...  what is some good practices to fix or keep this from happening persmissions  gone crazy i guess..     as i just use to windows and its always full access unless i set it to read only

Edited by comet424
Link to post

it was all files   at least my download..  i had issues last night with my music folder music was glitching or something but this morning my sister sent me some of her home videos in moi format  so i ran the mkvtool  i normally convert to mkv  and it wasnt allowing it.. it was giving errors couldnt write new file.. but if i coped the files to windows to my regular ntfs   and ran  mktool  had no issues.. and then i wasnt able to create a directory  forgot the error now..  

but once i ran the docker safe.. and ran the mkvtool on my sisters video files it was able to write to the directory  on the array..   i use the "downloads" share for all downloads.. 

Link to post

I use transmission and deluge but had them off.. well transmission was in pause mode.  but those 2  they download to a temp share on the array for incomplete and then moves to a "downloads\transmission complete" and a "downloads\deluge complete" folder   i was thinking going to use an unassigned drive for downloading.. and then when complete moves to the array?  not sure which is better

so windows be   "downloads\windows download"    sisters stuff "downloads\sisters stuff"

 

 

Link to post

and when i mentioned i had music issues.. i a DJ  and have my music on the array and i play directly  from there.. but had 2 really messed up crashes  and then this morning  i couldnt write to the array least the Downloads... so i was thinking maybe whole array was a read only or parts i have no idea

 

but my luck it wont show any errors in diagnostics as i didnt do it prior to a reboot and then ran  new persmissions new docker tools

Link to post

Nothing obvious in Diagnostics and maybe wouldn't tell us anything at the file level anyway. Is this a new problem?

 

Many applications will have a setting somewhere which controls permissions of files it creates. For example, transmission has umask in settings.json in its appdata.

 

We really need to take a look at a specific file or folder that is exhibiting the problem, so next time it happens post again to this thread before fixing it.

Link to post

ah ok well that sucks right..  now the unmask  is that the same as the pgid  and pid?  and or do you have to edit the settings.json?  and isn there just a broad template  always give full access?  or is that pgid pid  key 5 key6 

 

always learning  still not smart enough at linux thats for sure  

but ya this morning it was i guess folder issue  it didnt like any files   so it was like "downloads"  folder was read only it seemed   but who knows..  but ill do that ill post ahead of time..

and then the weird music software crashing on me  

 

technology is great till it breaks then you curse at it lol

 

Edited by comet424
Link to post

@trurl  so its happened again  had glitchs with  music and then my download folder

I found my transmission downloads wont let me rename files when I normally can.. can not delete

and my music share /map network drive went into a read only mode too it seems.. it wasn't able to write to that directory

I didn't reboot but I waited 8 hours to make diagnostic file so dunno it if it helps?  and in transmission json what rights would I be looking for... 

and why my map drive went into a read only mode for like 20 min.. I have tried different peoples ideas I read   for the 2 rights 0 0  or 100 99  or 1000 0   but the 0 0 seemed to work best here and in krusader but not sure what the 2 rights really should be for admin access

 

transmission 1.PNG

transmission 2.PNG

tower-diagnostics-20201101-0913.zip

transmission 3.PNG

Edited by comet424
Link to post
1 hour ago, trurl said:

PUID=99 PGID=100

ill re try that I used to have that too under Krusader  but it was giving me Issuesm as I reported in the krusader form issues but it seemed to fix if I went 0 0  from the 99 100... so when I went to the 0 0 in krusader it fixed that issue  reason I guess I had transmission set to 0 0   

and does the diagnostics say  anything why my Mapped drive on Unraid  my "music" share was stuck in a read only last night for a while

 

but ill change it back transmission

 

what does the 0 0 I have it set do what kinda permission is that

 

and what is the 1000 user permission..   ill have to google these later too later to read up on them    so much easier  check box's on permissions lol

 

Link to post

so 0 0 is ok for Krusader

but Transmission  to set to 99 100  is not on a different computer...  its a docker for unraid  so shouldn't it be 0 0 

or the files need to be saved as 99 100  so then I can access the files from other computers

so should I be changing the 0 0  on krusader back to 99 100  I did it because I was having issues transferring files from unassigned ntfs drives   and 0 0 fixed that issue 

as I planning to re changed my transmission to saved to a NTFS unassigned drive  so it keeps the array shut down to save drives  instead of saving to array  

 

and what is a 1000 user?

Link to post

the reason I changed  the krusader to use 0 0   

is when I had issues transferring like I mentioned  unassigned drive to  array or vise versa

 

but when I did it in windows from  the unassigned drive share to the array  windows had no issues  and vice versa  minus  windows protected like windows  folder

but I wanted to plug into  server and do it krusader   so it goes faster  and the 99 100 couldn't transfer  but the 0 0 did

 

so when do you use 99 100 and 0 0  but then have full access to files  from Windows  as id want root access all the time wouldn't I?

 

or do you after using Krusader  should then use the Docker Safe  or New Permissions  tool  so fixes all root moved files 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.