Cant connect to new homeassistant VM


wgstarks

Recommended Posts

This is my first VM and I'm guessing I've made some noob mistake.

 

I setup the homeassistant VM using this video- https://youtu.be/TSYL2PWQ3C4

After the VM is started I connect via NoVNC and get this-PreviewScreenSnapz005.thumb.jpg.71c9fba825d16dd594acc168619da7a4.jpg

 

When I try to connect to 192.168.122.8:8123 I get this error-

SafariScreenSnapz191.jpg.b2e8ef57219a553cf91dcae29fec93d2.jpg

 

Is there something I need to do to get access to the 192.168.122.0/24 network?

 

brunnhilde-diagnostics-20201025-1205.zip

 

Link to comment

192.168.122.0/24 network is the internal network of the KVM on unraid. So these IP's are only accessible from unraid server. What is selected for your "Network Bridge" in the VM configuration? If you use "br0" your router should assign the IP on your LAN and you should be able to access that.

Link to comment
3 hours ago, khartahk said:

192.168.122.0/24 network is the internal network of the KVM on unraid. So these IP's are only accessible from unraid server. What is selected for your "Network Bridge" in the VM configuration? If you use "br0" your router should assign the IP on your LAN and you should be able to access that.

Thanks for the reply. virbr0 is the only option available.

Link to comment

What do you have in https://tower.local/Settings/NetworkSettings 

 

These are my settings:

Enable bonding: Yes
Bonding mode: active-backup (1)
Bonding members of bond0: eth0
Enable bridging: Yes
Network protocol: IPv4 only
IPv4 address assignment: Automatic
IPv4 address: 192.168.X.Y/24
IPv4 default gateway: 192.168.X.Z
IPv4 DNS server assignment: Automatic
IPv4 DNS server: 192.168.X.Z
IPv4 DNS server 2: 1.0.0.1
IPv4 DNS server 3: 8.8.4.4
Desired MTU: 1500
Enable VLANs: No

 

  • Thanks 1
Link to comment
  • 6 months later...

Hoping this is appropriate for this thread:

Have HA Core Docker working along with ngnixproxymanager, and decided I want Supervisor.  The new HA Sup VM appears to be running per the VNC terminal, and I stopped the Docker's (even tried turning Docker off all-together), but I can't get http://homeassistant.local:8123/ or 192.168.0.112:8123 to connect.

What is this newb doing wrong?

chrome_JPmZU7QYgr.jpg

HA_VM_settings.pdf tower-diagnostics-20210508-0819.zip

Link to comment

In case someone finds this thread with my same issue, I finally figured it out after tons of trial-and-error, and research.  Though my network.cfg file seemed normal and intact, I found other instances where users couldn't select the network bridge br0 until they renamed/deleted network.cfg, so I tried it.  I then could select br0 in the VM HA setup & all works.  Now I just need to get the proxy working...

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.