****solved trouble getting Putty public key to work for passwordless SSH to unraid


Recommended Posts

Hi All I had this working sometime ago but my keys in windows dispapeared

I am trying to use the Puttygen tool to generate a new public key for my unraid server
here is what im doing please enlighten me if i messed up somewhere:

i run the puttygen to make a key and save it to a ppk and public file

i copy the public key to my authorized_keys file on unraid at /root/.ssh/authorized_keys
I set up putting to use the public file under SSH/Auth in putty.

I open putty and it wont autofill anything and still requires user and password to connect

my Linux Laptop on Fedora 32 works without any issues using the ssh-copy-id command but putty doesnt support ssh-copy-id

any help would be very much appreciated

Edited by Can0nfan
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.