UPS Status stuck on "Refreshing..." (SOLVED)


16 posts in this topic Last Reply

Recommended Posts

I have an APC Back-UPS ES 700VA connected via RJ45/USB cable to my unraid server and i am having an issue seeing its stats.

 

When using the built in "UPS Settings" the "UPS STATUS" is stuck showing "Refreshing..." and will never show any other information.

bQAl9fR.png

 

I'm not sure if there is something broken or if the firmware is corrupted or something.

 

The weird thing is that the NUT v2 UPS plugin works as intended and show all relevant information except for the UPS load only showing when on battery power.

 

Any ideas?

Edited by MammothJerk
Link to post
18 minutes ago, Vr2Io said:

For about ”refreshing", it should because you execute APCUPSD and NUT at the same time, pls uninstall NUT.

I had this issue before installing NUT, and I assumed stopping the NUT UPS tools service would be sufficient to not cause a conflict, but ive removed the NUT plugin anyway.

 

I still have the issue even after a complete server reboot and restarting the APC UPS daemon.

Edited by MammothJerk
Link to post

Searching for "APC" in the output only shows me this line and its surrounding

 

[   12.676866]  sda: sda1
[   12.678857] sd 0:0:0:0: [sda] Attached SCSI removable disk
[   12.831161] usb 3-7.1: new low-speed USB device number 8 using xhci_hcd
[   12.943735] input: HID 0557:2419 as /devices/pci0000:00/0000:00:14.0/usb3/3-7/3-7.1/3-7.1:1.0/0003:0557:2419.0003/input/input1
[   12.946475] hid-generic 0003:051D:0002.0004: hiddev98,hidraw2: USB HID v1.10 Device [APC Back-UPS ES 700G FW:871.O3 .I USB FW:O3 ] on usb-0000:00:14.0-9/input0
[   12.996334] hid-generic 0003:0557:2419.0003: input,hidraw3: USB HID v1.00 Keyboard [HID 0557:2419] on usb-0000:00:14.0-7.1/input0
[   12.998411] input: HID 0557:2419 as /devices/pci0000:00/0000:00:14.0/usb3/3-7/3-7.1/3-7.1:1.1/0003:0557:2419.0005/input/input2
[   12.999323] hid-generic 0003:0557:2419.0005: input,hidraw4: USB HID v1.00 Mouse [HID 0557:2419] on usb-0000:00:14.0-7.1/input1
[   13.061171] usb 3-10: new full-speed USB device number 9 using xhci_hcd
[   13.117035] random: fast init done

 

under system devices -> usb devices i have this line as well if it matters

Bus 003 Device 007:	ID 051d:0002 American Power Conversion Uninterruptible Power Supply

 

Edited by MammothJerk
Link to post
9 hours ago, Vr2Io said:

Pls also grep all APCUPSD from log or try search solution in forum ( I run APCUPSD / NUT as network client not local device )

 

 

root@tower:~# cat /var/log/syslog | grep "apcupsd"
Oct 30 21:18:51 tower root: Starting apcupsd power management:  /sbin/apcupsd
Oct 30 21:18:51 tower apcupsd[12378]: apcupsd 3.14.14 (31 May 2016) slackware startup succeeded
Oct 30 21:18:51 tower apcupsd[12378]: NIS server startup succeeded
Oct 30 21:20:54 tower apcupsd[12378]: apcupsd exiting, signal 15
Oct 30 21:20:54 tower apcupsd[12378]: apcupsd shutdown succeeded
Oct 30 21:20:56 tower apcupsd[24185]: apcupsd 3.14.14 (31 May 2016) slackware startup succeeded
Oct 30 21:20:56 tower apcupsd[24185]: NIS server startup succeeded
Oct 30 21:25:33 tower apcupsd[24185]: apcupsd exiting, signal 15
Oct 30 21:25:33 tower apcupsd[24185]: apcupsd shutdown succeeded
Oct 30 21:25:33 tower apcupsd[5352]: apcupsd 3.14.14 (31 May 2016) slackware startup succeeded
Oct 30 21:25:33 tower apcupsd[5352]: NIS server startup succeeded
Oct 30 21:25:39 tower apcupsd[5352]: apcupsd exiting, signal 15
Oct 30 21:25:39 tower apcupsd[5352]: apcupsd shutdown succeeded
Oct 30 21:25:39 tower apcupsd[5594]: apcupsd 3.14.14 (31 May 2016) slackware startup succeeded
Oct 30 21:25:39 tower apcupsd[5594]: NIS server startup succeeded
Oct 31 10:52:34 tower apcupsd[5594]: apcupsd exiting, signal 15
Oct 31 10:52:34 tower apcupsd[5594]: apcupsd shutdown succeeded
Oct 31 10:52:41 tower apcupsd[30126]: apcupsd 3.14.14 (31 May 2016) slackware startup succeeded
Oct 31 10:52:41 tower apcupsd[30126]: NIS server startup succeeded
root@tower:~# cat /var/log/syslog | grep "APCUPSD"
root@tower:~#

Nothing to indicate anything going wrong here...

 

I tried removing the USB cable, using a different slot, even using a 3.0 header and no change at all.

 

I found a new issue now though, with the USB cable COMPLETELY DISCONNECTED i still get the same behavior in the UPS settings, UPS status set to refreshing... and nothing else happening. so theres definitely SOMETHING wrong.

 

Oct 31 10:52:34 tower apcupsd[5594]: apcupsd exiting, signal 15
Oct 31 10:52:34 tower apcupsd[5594]: apcupsd shutdown succeeded
Oct 31 10:52:41 tower apcupsd[30126]: apcupsd 3.14.14 (31 May 2016) slackware startup succeeded
Oct 31 10:52:41 tower apcupsd[30126]: NIS server startup succeeded
Oct 31 10:52:41 tower kernel: hid-generic 0003:1B1C:0C10.0001: hid_field_extract() called with n (128) > 32! (deluged)
Oct 31 10:53:12 tower login[32238]: ROOT LOGIN on '/dev/pts/0'
Oct 31 11:09:56 tower kernel: usb 3-9: USB disconnect, device number 7
Oct 31 11:10:11 tower apcupsd[30126]: apcupsd exiting, signal 15
Oct 31 11:10:11 tower apcupsd[30126]: apcupsd shutdown succeeded
Oct 31 11:10:19 tower apcupsd[1422]: apcupsd 3.14.14 (31 May 2016) slackware startup succeeded
Oct 31 11:10:19 tower apcupsd[1422]: NIS server startup succeeded
Oct 31 11:10:19 tower kernel: hid-generic 0003:1B1C:0C10.0001: hid_field_extract() called with n (128) > 32! (swapper/5)
Oct 31 11:10:47 tower kernel: usb 3-2: new low-speed USB device number 10 using xhci_hcd
Oct 31 11:10:47 tower kernel: hid-generic 0003:051D:0002.0009: hiddev98,hidraw2: USB HID v1.10 Device [APC Back-UPS ES 700G FW:871.O3 .I USB FW:O3 ] on usb-0000:00:14.0-2/input0
Oct 31 11:10:58 tower apcupsd[1422]: apcupsd exiting, signal 15
Oct 31 11:10:58 tower apcupsd[1422]: apcupsd shutdown succeeded
Oct 31 11:11:02 tower apcupsd[4551]: apcupsd 3.14.14 (31 May 2016) slackware startup succeeded
Oct 31 11:11:02 tower apcupsd[4551]: NIS server startup succeeded
Oct 31 11:11:02 tower kernel: hid-generic 0003:1B1C:0C10.0001: hid_field_extract() called with n (128) > 32! (swapper/5)
Oct 31 11:12:04 tower apcupsd[4551]: apcupsd exiting, signal 15
Oct 31 11:12:04 tower apcupsd[4551]: apcupsd shutdown succeeded
Oct 31 11:12:09 tower apcupsd[8977]: apcupsd 3.14.14 (31 May 2016) slackware startup succeeded
Oct 31 11:12:09 tower apcupsd[8977]: NIS server startup succeeded
Oct 31 11:12:09 tower kernel: hid-generic 0003:1B1C:0C10.0001: hid_field_extract() called with n (128) > 32! (swapper/5)
Oct 31 11:12:30 tower kernel: usb 3-2: USB disconnect, device number 10
Oct 31 11:12:38 tower apcupsd[8977]: apcupsd exiting, signal 15
Oct 31 11:12:38 tower apcupsd[8977]: apcupsd shutdown succeeded
Oct 31 11:12:41 tower apcupsd[11059]: apcupsd 3.14.14 (31 May 2016) slackware startup succeeded
Oct 31 11:12:41 tower apcupsd[11059]: NIS server startup succeeded
Oct 31 11:12:42 tower kernel: hid-generic 0003:1B1C:0C10.0001: hid_field_extract() called with n (128) > 32! (swapper/5)
Oct 31 11:13:18 tower kernel: usb 3-3: new low-speed USB device number 11 using xhci_hcd
Oct 31 11:13:18 tower kernel: hid-generic 0003:051D:0002.000A: hiddev98,hidraw2: USB HID v1.10 Device [APC Back-UPS ES 700G FW:871.O3 .I USB FW:O3 ] on usb-0000:00:14.0-3/input0
Oct 31 11:14:08 tower apcupsd[11059]: apcupsd exiting, signal 15
Oct 31 11:14:08 tower apcupsd[11059]: apcupsd shutdown succeeded
Oct 31 11:14:13 tower apcupsd[18360]: apcupsd 3.14.14 (31 May 2016) slackware startup succeeded
Oct 31 11:14:13 tower apcupsd[18360]: NIS server startup succeeded
Oct 31 11:14:13 tower kernel: hid-generic 0003:1B1C:0C10.0001: hid_field_extract() called with n (128) > 32! (swapper/5)
Oct 31 11:17:58 tower kernel: usb 3-3: USB disconnect, device number 11
Oct 31 11:18:01 tower kernel: usb 3-4: new low-speed USB device number 12 using xhci_hcd
Oct 31 11:18:01 tower kernel: hid-generic 0003:051D:0002.000B: hiddev98,hidraw2: USB HID v1.10 Device [APC Back-UPS ES 700G FW:871.O3 .I USB FW:O3 ] on usb-0000:00:14.0-4/input0
Oct 31 11:18:15 tower apcupsd[18360]: apcupsd exiting, signal 15
Oct 31 11:18:15 tower apcupsd[18360]: apcupsd shutdown succeeded
Oct 31 11:18:18 tower apcupsd[2009]: apcupsd 3.14.14 (31 May 2016) slackware startup succeeded
Oct 31 11:18:18 tower apcupsd[2009]: NIS server startup succeeded
Oct 31 11:18:19 tower kernel: hid-generic 0003:1B1C:0C10.0001: hid_field_extract() called with n (128) > 32! (swapper/5)
Oct 31 11:18:25 tower kernel: usb 3-4: USB disconnect, device number 12
Oct 31 11:18:34 tower kernel: usb 3-2: new low-speed USB device number 13 using xhci_hcd
Oct 31 11:18:34 tower kernel: hid-generic 0003:051D:0002.000C: hiddev98,hidraw2: USB HID v1.10 Device [APC Back-UPS ES 700G FW:871.O3 .I USB FW:O3 ] on usb-0000:00:14.0-2/input0
Oct 31 11:18:42 tower apcupsd[2009]: apcupsd exiting, signal 15
Oct 31 11:18:42 tower apcupsd[2009]: apcupsd shutdown succeeded
Oct 31 11:18:46 tower apcupsd[3970]: apcupsd 3.14.14 (31 May 2016) slackware startup succeeded
Oct 31 11:18:46 tower apcupsd[3970]: NIS server startup succeeded
Oct 31 11:18:46 tower kernel: hid-generic 0003:1B1C:0C10.0001: hid_field_extract() called with n (128) > 32! (swapper/5)
Oct 31 11:25:04 tower kernel: usb 3-2: USB disconnect, device number 13
Oct 31 11:25:09 tower apcupsd[3970]: apcupsd exiting, signal 15
Oct 31 11:25:09 tower apcupsd[3970]: apcupsd shutdown succeeded
Oct 31 11:25:14 tower apcupsd[29666]: apcupsd 3.14.14 (31 May 2016) slackware startup succeeded
Oct 31 11:25:14 tower apcupsd[29666]: NIS server startup succeeded
Oct 31 11:25:14 tower kernel: hid-generic 0003:1B1C:0C10.0001: hid_field_extract() called with n (128) > 32! (swapper/5)
Oct 31 11:26:05 tower apcupsd[29666]: apcupsd exiting, signal 15
Oct 31 11:26:05 tower apcupsd[29666]: apcupsd shutdown succeeded
Oct 31 11:26:11 tower kernel: usb 3-2: new low-speed USB device number 14 using xhci_hcd
Oct 31 11:26:11 tower kernel: hid-generic 0003:051D:0002.000D: hiddev98,hidraw2: USB HID v1.10 Device [APC Back-UPS ES 700G FW:871.O3 .I USB FW:O3 ] on usb-0000:00:14.0-2/input0
Oct 31 11:26:20 tower apcupsd[1371]: apcupsd 3.14.14 (31 May 2016) slackware startup succeeded
Oct 31 11:26:20 tower apcupsd[1371]: NIS server startup succeeded
Oct 31 11:26:20 tower kernel: hid-generic 0003:1B1C:0C10.0001: hid_field_extract() called with n (128) > 32! (swapper/5)

 

Edited by MammothJerk
Link to post
  • 3 weeks later...
On 10/31/2020 at 6:26 PM, MammothJerk said:

Oct 31 11:18:19 tower kernel: hid-generic 0003:1B1C:0C10.0001: hid_field_extract() called with n (128) > 32! (swapper/5)

Don't know this device ID belongs to what device.

 

UPS disconnect immediately ....

 

Oct 31 11:17:58 tower kernel: usb 3-3: USB disconnect, device number 11

 

Oct 31 11:18:01 tower kernel: usb 3-4: new low-speed USB device number 12 using xhci_hcd

Oct 31 11:18:01 tower kernel: hid-generic 0003:051D:0002.000B: hiddev98,hidraw2: USB HID v1.10 Device [APC Back-UPS ES 700G FW:871.O3 .I USB FW:O3 ] on usb-0000:00:14.0-4/input0

 

Oct 31 11:18:34 tower kernel: usb 3-2: new low-speed USB device number 13 using xhci_hcd

Oct 31 11:18:34 tower kernel: hid-generic 0003:051D:0002.000C: hiddev98,hidraw2: USB HID v1.10 Device [APC Back-UPS ES 700G FW:871.O3 .I USB FW:O3 ] on usb-0000:00:14.0-2/input0

 

Oct 31 11:26:11 tower kernel: usb 3-2: new low-speed USB device number 14 using xhci_hcd

Oct 31 11:26:11 tower kernel: hid-generic 0003:051D:0002.000D: hiddev98,hidraw2: USB HID v1.10 Device [APC Back-UPS ES 700G FW:871.O3 .I USB FW:O3 ] on usb-0000:00:14.0-2/input0

 

Does RJ45/USB cable was official ??

It should be a 10 pin RJ45.

 

 

Edited by Vr2Io
Link to post

Whats throwing me is that other than the UPS load information not updating in realtime - NUT works without any problems.

 

It would seem that the issue is on the software side

 

edit: quick response 😁, ill try disconnecting iCue and get back to you

Edited by MammothJerk
Link to post
On 10/31/2020 at 3:14 AM, MammothJerk said:

show all relevant information except for the UPS load only showing when on battery power.

It is expected.

 

18 minutes ago, MammothJerk said:

Whats throwing me is that other than the UPS load information not updating in realtime - NUT works without any problems.

NUT show realtime power usage ? I don't think so, my first UPS BE-550G-UK won't show that in NUT nor APCUPSD, it is hardware limitation not software issue.

 

I just try troubleshoot why APCUPSD not work.

Edited by Vr2Io
Link to post
23 minutes ago, Vr2Io said:

OK

 

Seems relate Corsair iCue, could you try disconnect it ?

Oct 31 11:18:19 tower kernel: hid-generic 0003:1B1C:0C10.0001: hid_field_extract() called with n (128) > 32! (swapper/5)

https://forum.corsair.com/v3/showthread.php?t=189994&page=6

This seems to be it.

I unplugged the Commander Pro from its USB header and started the server again and it instantly connected to the APC UPS daemon with no problem.

Now the only issue i have left is not getting the relevant realtime UPS load, but as you say it's a hardware limitation so i would have to upgrade my UPS in the future 😁

 

Thanks a lot for your help!

Link to post

You found APCUPSD conflict with Corsair iCue 👍

Would you provide the exactly hardware info. so other member could quickly identify the problem device next time.

 

Edit : Got it .... Commander Pro

Edited by Vr2Io
Link to post
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.