Restart NGINX


3 posts in this topic Last Reply

Recommended Posts

I just finished some major upgrades on my storage servers for which they had to be taken offline. During this period unRAID (just an appserver, doesn't store things) restarted and when it tried to access the container's appdata directory which had been moved outside unRAID thus was offline it sort of went downhill from there. unRAID still boots up normally but the problem is that configuration-virgin containers do too and because of that they steal the port for the webGUI away from unRAID and I can't access it to remount appdata. Is there a chance mount -a could work? I have not tried it because external mounts are done through a plugin -- Unassigned Devices.

 

I SSHed in and stopped all containers but this wasn't enough to bring the GUI back. It worked once before but now it's too far gone. By tab-completion I got a match for nginx and no match for httpd, apachectl, a2en*, so I assume NGINX runs the web GUI. How do I restart it? There's no systemd in unRAID and I don't have enough Linux experience to have dealt with initd I believe it's called, IDK; or even if it is that at all what's running things in unRAID.

 

If I restart unRAID altogether Docker will restart as well unless I delete the containers. I would, I actually have a text file for each of them with their settings--some of them were not deployed using the unRAID GUI--but there are two I forgot to document and I'd prefer not to start over. They are of the more complicated permission-specific types.

 

Thanks.

Edited by vitaprimo
Replaced mistakenly-expected inline code substitution for underlining
Link to post

Nevermind! I just realized that if I have appdata elsewhere, I just need to wipe unRAID and start over, I don't have to start over container-wise and I can copy the network settings from SSH or directly from the flash drive. Network and Docker are the most cumbersome areas to setup, so I'm all set. :D

Link to post

Nevermind my nevermind! I just found this:

root@zx2:/boot/config# cat docker.cfg 
DOCKER_ENABLED="yes"
DOCKER_IMAGE_FILE="/mnt/user/system/docker/docker.img"
DOCKER_IMAGE_SIZE="20"
DOCKER_APP_CONFIG_PATH="/mnt/user/appdata/"
DOCKER_APP_UNRAID_PATH=""
DOCKER_CUSTOM_NETWORKS=" "
DOCKER_LOG_ROTATION="yes"
DOCKER_LOG_SIZE="50m"
DOCKER_LOG_FILES="1"
DOCKER_AUTHORING_MODE="yes"
DOCKER_USER_NETWORKS="preserve"

I have a feeling that if I set the first line to no/false/0, all will be fixed. :D

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.