[Plugin] DVB-Driver


ich777

148 posts in this topic Last Reply

Recommended Posts

  • Replies 147
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

DVB-Driver (only Unraid 6.9.0beta35 and up) This Plugin will add DVB Drivers to Unraid. Please note that this Plugin is community driven and if a newer version of Unraid is released the driv

@anon1105 may ask in his support thread, maybe some dependencies not added in his container ...

it shouldnt matter, plugin runs anytime, docker runs only when docker engine is running (array is up)   descrambling is working nice on both so you rather should take a look at your setup(s)

Posted Images

14 minutes ago, Maginos said:

Works like a charm! Thank you very much for your help!

Do you think it was necessary to install the plugin or would it have also worked with the correct path for the adapter under unraid 6.8.3?

Glad to hear that everything works now!

 

You have to install the plugin because you need the modules and also the firmware that comes with this plugin. :)

Link to post
On 12/17/2020 at 7:53 PM, ich777 said:

Open up a Unraid terminal and give me the output of: 'ls -l /dev/dvb'

 

Can you post your diagnostics here?

Hi @ich777, thanks for your work on this new plugin.

I'm also getting a "dvb_core not found" error during system startup.

Subsequently my AF9015 USB sticks aren't getting initialised properly, but I think it's due to the AF9015 firmware not being available during initialisation first time, as when I remove the sticks and re-insert them, the firmware is loaded fine, and /dev/dvb gets created.

Attached is my syslog

syslog.zip

Link to post
5 hours ago, Zan said:

Hi @ich777, thanks for your work on this new plugin.

I'm also getting a "dvb_core not found" error during system startup.

Subsequently my AF9015 USB sticks aren't getting initialised properly, but I think it's due to the AF9015 firmware not being available during initialisation first time, as when I remove the sticks and re-insert them, the firmware is loaded fine, and /dev/dvb gets created.

Attached is my syslog

Please always attach the full diagnostics, the output of lsmod would be also really helpfull (but without the adapters repluged).

 

The firmware is available after the installation of the plugin and after that the plugin tries to load the modules/firmware for the adapters otherwise no card will ever work. It's more of a USB thing I think.

 

Here you can see that the adapters are initialized successfully (actually this is one of them):

Jan  4 12:03:30 Tower kernel: usb 3-9: dvb_usb_v2: found a 'Afatech AF9015 reference design' in warm state
Jan  4 12:03:30 Tower kernel: usb 3-9: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
Jan  4 12:03:30 Tower kernel: dvbdev: DVB: registering new adapter (Afatech AF9015 reference design)
Jan  4 12:03:30 Tower kernel: usb 3-9: media controller created
Jan  4 12:03:30 Tower kernel: dvbdev: dvb_create_media_entity: media entity 'dvb-demux' registered.
Jan  4 12:03:30 Tower kernel: i2c i2c-1: Added multiplexed i2c bus 2
Jan  4 12:03:30 Tower kernel: af9013 1-001c: Afatech AF9013 successfully attached
Jan  4 12:03:30 Tower kernel: af9013 1-001c: firmware version: 5.24.0.0
Jan  4 12:03:30 Tower kernel: usb 3-9: DVB: registering adapter 0 frontend 0 (Afatech AF9013)...
Jan  4 12:03:30 Tower kernel: dvbdev: dvb_create_media_entity: media entity 'Afatech AF9013' registered.
Jan  4 12:03:30 Tower kernel: mxl5007t 2-0060: creating new instance
Jan  4 12:03:30 Tower kernel: mxl5007t_get_chip_id: MxL5007T.v4 detected @ 2-0060
Jan  4 12:03:30 Tower kernel: usb 3-9: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
Jan  4 12:03:30 Tower kernel: dvbdev: DVB: registering new adapter (Afatech AF9015 reference design)

 

Also where did you get the error that dvb_core is not found, I can't find anything related to that in your syslog.

Link to post

for TBS 6909 doesn't work 

04:00.0 Multimedia controller: TBS Technologies DVB Tuner PCIe Card
Subsystem: Device 6909:0001
Flags: bus master, fast devsel, latency 0, IRQ 55, IOMMU group 16
Memory at f7300000 (32-bit, non-prefetchable) [size=256K]
Capabilities: [50] Power Management version 3
Capabilities: [70] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [90] Express Endpoint, MSI 00
Capabilities: [100] Device Serial Number 00-00-00-00-00-00-00-00
Kernel driver in use: TBSECP3 driver
Kernel modules: tbsecp3

 

[   92.690435] TBSECP3 driver 0000:04:00.0: TurboSight TBS 6909 DVB-S/S2 
[   92.690874] dvbdev: DVB: registering new adapter (TBSECP3 DVB Adapter)
[   92.813154] TBSECP3 driver 0000:04:00.0: MAC address 00:22:ab:91:8a:a8
[   92.848084] i2c i2c-1: Hydra chip version 2
[   92.854077] i2c i2c-1: loading firmware, please wait...
[   95.185171] ipmi device interface
[  119.039131] i2c i2c-1: Hydra FW alive
[  119.093586] i2c i2c-1: chipID=00000001
[  119.095225] i2c i2c-1: chipVer=00000002
[  119.096875] i2c i2c-1: FWVer=0202010a
[  119.126587] TBSECP3 driver 0000:04:00.0: DVB: registering adapter 0 frontend 0 (TurboSight TBS 6909 DVB-S/S2 )...
[  119.126731] dvbdev: DVB: registering new adapter (TBSECP3 DVB Adapter)
[  119.249904] TBSECP3 driver 0000:04:00.0: MAC address 00:22:ab:91:8a:a9
[  119.249914] TBSECP3 driver 0000:04:00.0: DVB: registering adapter 1 frontend 0 (TurboSight TBS 6909 DVB-S/S2 )...
[  119.250034] dvbdev: DVB: registering new adapter (TBSECP3 DVB Adapter)
[  119.357599] TBSECP3 driver 0000:04:00.0: MAC address 00:22:ab:91:8a:aa
[  119.357607] TBSECP3 driver 0000:04:00.0: DVB: registering adapter 2 frontend 0 (TurboSight TBS 6909 DVB-S/S2 )...
[  119.357725] dvbdev: DVB: registering new adapter (TBSECP3 DVB Adapter)
[  119.480823] TBSECP3 driver 0000:04:00.0: MAC address 00:22:ab:91:8a:ab
[  119.480831] TBSECP3 driver 0000:04:00.0: DVB: registering adapter 3 frontend 0 (TurboSight TBS 6909 DVB-S/S2 )...
[  119.480949] dvbdev: DVB: registering new adapter (TBSECP3 DVB Adapter)
[  119.603888] TBSECP3 driver 0000:04:00.0: MAC address 00:22:ab:91:8a:ac
[  119.603895] TBSECP3 driver 0000:04:00.0: DVB: registering adapter 4 frontend 0 (TurboSight TBS 6909 DVB-S/S2 )...
[  119.603957] dvbdev: DVB: registering new adapter (TBSECP3 DVB Adapter)
[  119.727119] TBSECP3 driver 0000:04:00.0: MAC address 00:22:ab:91:8a:ad
[  119.727139] TBSECP3 driver 0000:04:00.0: DVB: registering adapter 5 frontend 0 (TurboSight TBS 6909 DVB-S/S2 )...
[  119.727311] dvbdev: DVB: registering new adapter (TBSECP3 DVB Adapter)
[  119.850890] TBSECP3 driver 0000:04:00.0: MAC address 00:22:ab:91:8a:ae
[  119.850907] TBSECP3 driver 0000:04:00.0: DVB: registering adapter 6 frontend 0 (TurboSight TBS 6909 DVB-S/S2 )...
[  119.851072] dvbdev: DVB: registering new adapter (TBSECP3 DVB Adapter)
[  119.967030] TBSECP3 driver 0000:04:00.0: MAC address 00:22:ab:91:8a:af
[  119.967047] TBSECP3 driver 0000:04:00.0: DVB: registering adapter 7 frontend 0 (TurboSight TBS 6909 DVB-S/S2 )...
[  119.967240] TBSECP3 driver 0000:04:00.0: TurboSight TBS 6909 DVB-S/S2 : PCI 0000:04:00.0, IRQ 55, MMIO 0xf7300000

 

but when I looking into /dev/dvb I see only adapter0/ adapter1/ adapter2/ adapter3/ adapter4/ adapter5/ adapter6/ adapter7/

but nothing more like before tuner, dvr, ca, etc 

Link to post
1 hour ago, piotrasd said:

for TBS 6909 doesn't work 

I tested it only with a TBS-6902 and it works just fine with the TBS-OS drivers.

 

What drivers are you using? Have you rebooted after you installed the plugin? This seems fine to me, have you the folders 'demux0', 'dvr0', 'frontend0',... in the folder /dev/devb/adapter0/?

 

EDIT: Please keep in mind that you also have to reboot if you change the Packages from one to another.

Link to post
8 hours ago, piotrasd said:

nothing /dev/dvb/adapter0/ under this directory and others which is weird

 

and im using tbs-os

yes i rebooted few times

That is really weired, does this card's need any boot arguments like the DD Max S8?

Can you post the Diganostics from your server?

 

Also please try the LibreELEC drivers just for testing.

 

The next thing you can try is to build custom images with the Unraid-Kernel-Helper...

Link to post
On 1/4/2021 at 6:17 PM, ich777 said:

Please always attach the full diagnostics, the output of lsmod would be also really helpfull (but without the adapters repluged).

 

The firmware is available after the installation of the plugin and after that the plugin tries to load the modules/firmware for the adapters otherwise no card will ever work. It's more of a USB thing I think.

 

Here you can see that the adapters are initialized successfully (actually this is one of them):


Jan  4 12:03:30 Tower kernel: usb 3-9: dvb_usb_v2: found a 'Afatech AF9015 reference design' in warm state
Jan  4 12:03:30 Tower kernel: usb 3-9: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
Jan  4 12:03:30 Tower kernel: dvbdev: DVB: registering new adapter (Afatech AF9015 reference design)
Jan  4 12:03:30 Tower kernel: usb 3-9: media controller created
Jan  4 12:03:30 Tower kernel: dvbdev: dvb_create_media_entity: media entity 'dvb-demux' registered.
Jan  4 12:03:30 Tower kernel: i2c i2c-1: Added multiplexed i2c bus 2
Jan  4 12:03:30 Tower kernel: af9013 1-001c: Afatech AF9013 successfully attached
Jan  4 12:03:30 Tower kernel: af9013 1-001c: firmware version: 5.24.0.0
Jan  4 12:03:30 Tower kernel: usb 3-9: DVB: registering adapter 0 frontend 0 (Afatech AF9013)...
Jan  4 12:03:30 Tower kernel: dvbdev: dvb_create_media_entity: media entity 'Afatech AF9013' registered.
Jan  4 12:03:30 Tower kernel: mxl5007t 2-0060: creating new instance
Jan  4 12:03:30 Tower kernel: mxl5007t_get_chip_id: MxL5007T.v4 detected @ 2-0060
Jan  4 12:03:30 Tower kernel: usb 3-9: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
Jan  4 12:03:30 Tower kernel: dvbdev: DVB: registering new adapter (Afatech AF9015 reference design)

 

Also where did you get the error that dvb_core is not found, I can't find anything related to that in your syslog.

Attached is photo of the console messages showing dvb_core not found. Also syslog.txt and lsmod.txt from a second boot of the machine.

There are mxl5007t errors. I've tried modprobe mxl5007t in /boot/config/go and that didn't help.

 

 

IMG_20210104_203827.jpg

lsmod.txt syslog.txt

Edited by Zan
Link to post
2 minutes ago, Zan said:

Attached is photo of the console messages showing dvb_core not found. Also syslog.txt and lsmod.txt from a second boot of the machine

That first initialisation

From the output of your 'lsmod' the module 'dvb_core' is definitely loaded, I think it has something to do with the initialization itself, what you can do is try to generate a Custom build of Unraid with the DVB-Drivers included with the Unraid-Kernel-Helper (it's a really simple process):

 

Link to post
2 hours ago, ich777 said:

From the output of your 'lsmod' the module 'dvb_core' is definitely loaded, I think it has something to do with the initialization itself, what you can do is try to generate a Custom build of Unraid with the DVB-Drivers included with the Unraid-Kernel-Helper (it's a really simple process):

 

No worries. Good to have that as a fall-back. I appreciate your help and thanks for this plug-in and the kernel helper docker. Keep up the great work.

Link to post

In my first post ever in unRAID forums, I would like thank you @ich777 for the amazing job you are doing and the value you are adding to unRAID community as you making plugins that made my unRAID build feasible. I'm amazed how unRAID users are passionate which is the real reason I chose unRAID.

 

In your original post you mentioned that the plugin downloads a custom bzimage and kernel modules and wondering what is if things went wrong. Do i just uninstall the plugin and unRAID will be back as I didn't install the plugin? Does it have permanent effect?

 

I mainly use containers because they can be disposed easily without leaving any orphan files and they don't change anything in the host system if you don't allow them to. I'm asking this question because I have 2 tbs 6909 which I would like to test them with tvheadend and as per the post above it could not work as intended. Or maybe I just should use ubuntu VM to install the drivers and tvheaded?

 

Please excuse my question if it sounds stupid, as I'm new here and still learning how things work in unRAID. Thanks in advance for the support.

Link to post
26 minutes ago, Ziryab said:

In your original post you mentioned that the plugin downloads a custom bzimage and kernel modules and wondering what is if things went wrong. Do i just uninstall the plugin and unRAID will be back as I didn't install the plugin?

Exactly, it will revert all back to default if something fails or you uninstall the plugin.

 

26 minutes ago, Ziryab said:

I'm asking this question because I have 2 tbs 6909 which I would like to test them with tvheadend and as per the post above it could not work as intended.

Not every system is the same please try it first and then we could troubleshoot it. :)

Keep in mind that these cards should work with LibreELEC and also with the TBS-OS drivers, please test both if possible and one doesn't work (You can select the drivers on the Plugin page).

 

26 minutes ago, Ziryab said:

Or maybe I just should use ubuntu VM to install the drivers and tvheaded?

My DigitalDevices cards run just fine with this Plugin and the TVHeadend Container from linuxserver, eventually you can also try my Unraid-Kernel-Helper where you can integrate everything into the images itself if the Plugin doesn't work for you.

 

Appreciated the nice words. :)

 

EDIT: A buddy runs the TBS-OS drivers just fine with his TBS-6902

Link to post
24 minutes ago, ich777 said:

Exactly, it will revert all back to default if something fails or you uninstall the plugin.

 

Not every system is the same please try it first and then we could troubleshoot it. :)

Keep in mind that these cards should work with LibreELEC and also with the TBS-OS drivers, please test both if possible and one doesn't work (You can select the drivers on the Plugin page).

 

My DigitalDevices cards run just fine with this Plugin and the TVHeadend Container from linuxserver, eventually you can also try my Unraid-Kernel-Helper where you can integrate everything into the images itself if the Plugin doesn't work for you.

 

Appreciated the nice words. :)

 

EDIT: A buddy runs the TBS-OS drivers just fine with his TBS-6902

Sure I will do that tomorrow as soon as the satellite guy runs 8 cables to my server room! :/

 

By the way, your Nvidia plugin is working perfectly in linuxserver plex container (decoding and encoding) with my P2200 out of the box, I didn't have to do anything extra other than following your guide.

Link to post
2 minutes ago, Ziryab said:

By the way, your Nvidia plugin is working perfectly in linuxserver plex container (decoding and encoding) with my P2200 out of the box, I didn't have to do anything extra other than following your guide.

Glad to hear that everything works ;)

 

3 minutes ago, Ziryab said:

Sure I will do that tomorrow as soon as the satellite guy runs 8 cables to my server room! :/

Please feel free to contact me again if something isn't working but it should at least... :)

Link to post

Hi @ich777 and sorry for bothering you again. Unfortunately not all of my TV channels work normally in tvheadend. One channel (Sport1 in specific) shows laggy picture and interrupted sound. Please find the log output in the annex. All other channels work as expected. In the vm I have the same problem. Can you also help me with this? 

Thank you again for your help!

Tvheadend_log.txt

Link to post
10 hours ago, Maginos said:

Hi @ich777 and sorry for bothering you again. Unfortunately not all of my TV channels work normally in tvheadend. One channel (Sport1 in specific) shows laggy picture and interrupted sound. Please find the log output in the annex. All other channels work as expected. In the vm I have the same problem. Can you also help me with this? 

Thank you again for your help!

This seems like a waek signal or other kind of problem, nothing that I really can help with.

Eventually look at this thread: Click

Link to post

@ich777 and @alturismo thank you for your help.

as it turned out, its unfortunately not only Sport1, its also DMAX.

The situation is the following:

Before I used the TVH docker container, I used a raspi and the cable from the satellite was directly going into the usb adapter on the pi. With this setup, all channels worked normally. The unraid server is in the back of my room and the cable from the satellite too short, so I had to connect another cable to get to the unraid server. With this prolonged cable, the two channels don't work neither on the pi, nor on unraid, so the problem should be the cable. I ordered a new cable and a new connector for the two cables and I hope, that this will solve my problem. A rescan is indeed a good idea, thank you for that.

Link to post

Hi,

 

Thank you for this plugin, it works straight out of the box with my USB DVB-T cards.

 

One question tho, is there a way to compile the kernal with a 16 Tuner limit instead of 8 (dont ask why I have more than 8 lol)

 

Regards,

 

Adrian

 

Link to post

@ich777 and @alturismo I got it! 
FYI: The new extension did unfortunately not bring the solution, but extension of the USB cable did. So no I have the cable from the satellite directly plugged in the usb adapter and the usb cable from the adapter is extended to the server. Now, all channels work as expected.

Link to post
7 hours ago, Maginos said:

@ich777 and @alturismo I got it! 
FYI: The new extension did unfortunately not bring the solution, but extension of the USB cable did. So no I have the cable from the satellite directly plugged in the usb adapter and the usb cable from the adapter is extended to the server. Now, all channels work as expected.

nice, enjoy now ;)

Link to post
10 hours ago, Spriggy said:

One question tho, is there a way to compile the kernal with a 16 Tuner limit instead of 8 (dont ask why I have more than 8 lol)

This plugin should be compiled with a tuner limit of 16.

Have you rebooted after you installed the plugin?

Link to post
4 hours ago, ich777 said:

This plugin should be compiled with a tuner limit of 16.

Have you rebooted after you installed the plugin?

I did reboot the server once I installed the Plugin.

 

What I have plugged in at the moment is 3 x Sony Playtv Tuners and I am using the libreelec drivers.

When I have 2 plugged in TVheadend (linuxserver.io version 4.2.8), it sees 4 tuners and tunes fine.

When I add a third it detects the 6 tuners in the config page but only 5 in the wizard page for tuning.

 

Should I be using a different driver? Or is this a TVheadend issue?

 

Regards,

 

 

tvheadend 3 playtv.png

tvheadend tuner config.png

unraid dvb plugin.png

Edited by Spriggy
forgot a picture
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.