Unraid crashes and there is lots of text scrolling on screen

Recommended Posts

This has been happening none stop since I've built my machine. I've tried debugging myself and have no clue what is happening. It use to happen every 2 weeks but is now happening every day or two and it's driving me crazy. 


Attached are the diagnostics, I have it syncing to flash, and the video of what I see when I plug Unraid into a screen after it crashes. 


I am aware disk 3 is failing, that started today and a new drive has been ordered. 

I've run memtest several times now and all runs have been left to run 24h or longer and at least 3 passes each time with no error. I'm confident it isn't the ram. 


Any help or advise is much appreciated! 


Link to comment

I've disabled the Global C-state in the bios and set ram speeds to 1866 (If I understood it correctly, I have a 2700x and 4 stick of this ram)


Now my server has locked up (about 2 days). I am unable to access the web ui, but when I go to the physical box I was able to login and type in 1 command. The command will not execute but I was able to continue typing :/ 


Link to comment

some people seem to have no issues with ryzen, I did have issues.  lowering the ram speed of my 2200G to stock fixed the instability issues.

all the other 'tricks' seemed to have no effect in solving my 'blowing up under heavy cpu/disk io' case.


In the end I got a intel i5-10400 and all the problems I had went away.

The old ryzen system is now a windows desktop with no issues.


Link to comment

I'm at my wits end. I've gone though just about everything trying to debug this for the past couple months. 


It crashed again at 1day 23h 43min. Screenshot is attached and shows what I see on screen. I have;

- updated bios

- updated unraid

- disabled c state

- put `rcu_nocbs=0-15` in the Syslinux configuration

- set ram speed to 1866

- added a vlan to my network settings


I just don't know what to do anymore. 


On 12/11/2020 at 5:03 PM, rilles said:

some people seem to have no issues with ryzen, I did have issues. 

Honestly, I'm convinced there should be a massive "not recommended with AMD chips" at the front of the unraid page if this is a common enough problem. 


On 12/11/2020 at 5:03 PM, rilles said:

In the end I got a intel i5-10400

I wish I had the funds to change my hardware. 

Edited by 5252525111
Link to comment

I have a 2200G and from my research this seems to actually be a first gen Zen1 and a GPU added, my theory is it something about unraid does not like this cpu and chipset.  I recently put Ubuntu 20.04 on my ryzen board and no issues at all (even with ram at 3200) and no 'tricks' to make it work.


From above it appears you have a 2700x, so maybe more cpu/mobo combos have issues. Have you tried unraid 6.9.beta?  it has a newer kernel that may solve some of the issues you are having.  I bought my ryzen last year and it pained me to give up on it, plus the $$ I had to shell out.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.