VNC Failed to Connect After Adding New VM


2 posts in this topic Last Reply

Recommended Posts

I've had an Ubuntu VM running on my server for several months now. I connect to it using the noVNC option built into Unraid. Yesterday I tired adding a second Ubuntu VM for a new task. After starting the new VM I was unable to connect to either it or the old VM. NoVNC simply reports "Failed to connect to server". I deleted the new VM but still could not connect to the old VM. I tried restoring from a saved libvirt image, which involved resetting the server altogether, but still could not connect. My only other VM is a Windows machine hooked up to a GPU and monitor, this works fine.

 

I get the following error in the Unraid logs each time I attempt to connect to the VM via noVNC:

 

Tower nginx: 2021/03/15 09:30:55 [error] 10278#10278: *1827 recv() failed (104: Connection reset by peer) while reading upstream, client: 10.10.20.164, server: , request: "GET //wsproxy/5700/ HTTP/1.1", upstream: "http://127.0.0.1:5700/", host: "10.10.20.2"

 

Any advice on how to fix this would be much appreciated.

 

I am running Unraid 6.9

 

Thank you

Link to post

It turns out the problem was not with the server but rather with Chrome. I was able to get noVNC to connect using Edge, which prompted me to restart Chrome and then it worked. I had tried using Edge to connect previously with no luck, but I don't think I had tried again since restoring the libvirt image. Glad it is working now, but I still do not know why adding the new VM broke things in the first place. 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.