Jump to content

Plex Docker Preferences.xml Blank

Recommended Posts

I'm going to apologize in advanced for this being an obscure request for help.  I'm really not sure where to start.  


A couple of weeks ago my plex server was unresponsive.  After logging into unraid's management interface and pulling up the docker logs I got an error message that said something along the lines of "preferences.xml" could not be read.  When I opened my appdata folder to check that file it was completely blank.  I did have a backup from appdata backup/restore and managed to replace the blank file.  Plex started back up just fine and I went on my merry way, for about a day until this happened again a couple of more times.  During these instances I also noticed that my unraid machine was not reachable at times, almost like there was a network problem.  A reboot usually corrects this issue.  


I've tried a few things.  At first, I thought somehow my pihole instance (running separately on an ubuntu server) was screwed up and I was having DNS issues.  So, I did a fresh install of pihole. Things seemed to be working great until last night when my plex server was unresponsive again.  I also could not log into my unraid machine.  One thing I tried differently last night was I bypassed one of my network switches thinking possibly it could be going bad (I run a unifi network and my server was going through a USW-48 switch).  We will see if that somehow corrects the issue.  


I guess my main question here is, does anyone have any idea what could be causing my "preferences.xml" to wipe itself like this?  It seems somehow connected to network issues either with my server or with my netowrk hardware or software.  I suppose these all could be symptoms of failing hardware, but I'm unsure of what steps I can take to diagnose that.

Link to comment

Follow up post.  It's happened again.  My server has become unresponsive.  I had to reboot it to get it back, but it came back up.  I've attached my diagnostics.  I noticed on the startup screen I get the following error:


modprobe: ERROR: could not insert 'nct6775': No such device


So, this does appear to be either a system or hardware error, not a plex thing.  Any ideas?


Link to comment
  • 5 months later...
18 hours ago, jevis said:

Did you find out whats happening. I am having the same problem .. once or twice a week the preferences.xml some how ends up empty.

I am not sure what caused it, but I no longer have this issue.  I suspect that it was some sort of bug in the Ubiquiti software that was triggering something.  I took my 48 port switch and my pi-hole machine out of my network stack trying to eliminate possible causes, and one of those seems to have resolved it.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...