Jump to content

Unraid becomes unresponsive and High read speeds on Cache disk


Recommended Posts

Hello guys, something like this has happened before at least 3 or 4 times.

32GB ddr4 ram
LSi 9207-8i 

Yesterday i installed VaultHunters3rdEdition container with 2 cores pinned to test and play a friend, i was able to play alone for the most part but sometimes the server would lag behind and crash because one tick took to long, installed the server on the pc to pregen the chunks and after transfering the world to the server i never had tick problems so bad that it would crash the container.
After my friend joined we were able to get what we needed to go into a vault and when we tried using the portal the minecraft server would disconnect us and eventually say in the console it took too long for a tick and crashed but at the same time the unraid server would become unresponsive to almost everything, mainly the UI and i would start to get notifications from home assistant(running in a VM) that uptime kuma was reporting all of the services down because they timed out, for example plex, nextcloud and fireshare.


As this was happening i was able to load the main tab and see that the cache with system and domains was getting really high constant reads above 100 to 240MB/s, my appdata and some of the shares that use cache are on a separate cache disk.

I was able to connect using ssh and at first i shutdown plex thinking is was the culprit for the high reads based on a post i saw on reddit, but after starting the minecraft server again and trying to use the portal it happened again the minecraft server crashed and Unraid server becaues unresponsive, after using ssh to stop the minecraft server, almost immediately the unraid server became responsive again.

I also had something like this happen before a couple of times that would make unraid unresponsive but without the minecraft server, iirc i was trying to edit a collective file in nextcloud, for example i tried pasting something and it would freeze and i had to let it run for a couple of minutes and the high reads would return to normal but still not able to edit the collective.

All of the times that Unraid was unresponsive i could still load homeassistant without problems and its running in a VM.


I also saw on reddit that this might be fixed by change the cache pool to XFS?

I'm including the first diagnostics file that i managed to download while the server was still unresponsive and it was the first time and a second one that i just downloaded that should have more info since after the first diagnostics file it happened another 2 or 3 times.


Thanks in advance for the support.

unraid-server-diagnostics-20230110-0008.zip unraid-server-diagnostics-20230110-1446.zip

Edited by Toino
Link to comment

Started the minecraft server again and after around 10 minutes i timed out of the server and Unraid became unresponsive, but this time i had netdata on and got a bit more info but i still don't know what can cause this, its seems that its because unresponsive because of iowait, after ac couples of minutes it returned to normal.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...