Mount share with support for symlinks and uid/gid

Recommended Posts


Usually I am mounting a share to Windows with SMB, which works fine. But now i have a special case. I need to mount a share to a Raspberry Pi and need support for file ownership, symlinks and read/write support. I tried to use SMB but it seems like the unix extensions are disable and I am not able to activate them for only one share. I have also tried NFS but with no luck.


So my question is: What is the best way to mount a share (or parts of a share) to another Linux machine? NFS / SMB or something totally different?

Link to comment

Well, it turns out that the permissions you see in the mounted folder are not the same as on the server itself (when you are forcing them with file_mode and dir_mode). Today i learned. Now the root cause sounds really stupid, to be honest 🙂

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.