Cached NFS-shares are not permanently mountable!


Recommended Posts

I ran into an issue recently, when trying to mount a SSD cached share on my Enigma2 Linux receiver permanently, to store my recordings directly onto my unraid server!


I use fstab to mount the share (just added nfsvers=4 while investigating the error; not needed): /media/recordings nfs _netdev,nfsvers=4,rw 0 0


It works till the mover moves the recordings from SSD cache pool into the array.

After that i get the following errors on the fstab-mounted nfs share on my receiver:


[email protected]:~$ mount -t nfs /media/recordings
mount.nfs: Stale file handle

[email protected]:~$ rpcinfo -p
   program vers proto   port  service
    100000    4   tcp    111  portmapper
    100000    3   tcp    111  portmapper
    100000    2   tcp    111  portmapper
    100000    4   udp    111  portmapper
    100000    3   udp    111  portmapper
    100000    2   udp    111  portmapper
    100024    1   udp  34064  status
    100024    1   tcp  47303  status
    100003    3   tcp   2049  nfs
    100003    4   tcp   2049  nfs
    100021    1   udp  49947  nlockmgr
    100021    3   udp  49947  nlockmgr
    100021    4   udp  49947  nlockmgr
    100021    1   tcp  41379  nlockmgr
    100021    3   tcp  41379  nlockmgr
    100021    4   tcp  41379  nlockmgr
    100005    1   udp  60889  mountd
    100005    1   tcp  50843  mountd
    100005    2   udp  33420  mountd
    100005    2   tcp  55269  mountd
    100005    3   udp  59744  mountd
    100005    3   tcp  55475  mountd
[email protected]:~$ showmount -e
Export list for
/mnt/user/media       *
/mnt/user/recordings   *

[email protected]:~$ ls -l /media/recordings
ls: /media/recordings: Stale file handle

[email protected]:~$ showmount -a
clnt_create: RPC: Program not registered

[email protected]:/media$ cat /proc/mounts | grep nfs
nfsd /proc/fs/nfsd nfsd rw,relatime 0 0 /media/recordings nfs4 rw,relatime,vers=4.0,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=,local_lock=none,addr= 0 0


AFAIK, this can be solved by un-exporting and re-exporting the relevant exports on the server:


exportfs -ua
exportfs -a


and afterwards manually mounting the nfs share on the receiver, mount -t nfs ...


But, idk how to schedule this?

E.g.: I have several docker containers running, but the mover moves, although I never put them down.

I set the daily mover schedule to 05:45, but realized that the other day the mover moved my recordings somewhere around 17:00 (maybe even 17:45 - but there is no AM/PM setting? Therefore, i think this is just a coincidence.).

So i can't schedule a cron job for manual mounting my recordings share -> NFS-Shares that must be permanently mounted can not be cached!


When deactivating the SSD-Cache and directly using the HDD within my Array it seems to work.


Would appreciate the cached solution though.

Edited by theuema
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.