Jump to content

Trouble connecting to unraid or dockers when device is not within the same subnet


Recommended Posts

So before I get into this I am a super newbie and feel like I'm just missing something super easy. Also, sorry for the long diatribe ahead. I just want to convey in detail what I've tried so far.

 

I've set up Unraid (tried 6.12.0 and 6.11.5) on an old computer to serve as a home server. I set up my docker containers and everything works well within the same subnet. Meaning: My server is on 192.168.2.100 and any device with IP 192.168.2.whatever can connect to the Unraid GUI or the GUI of any of the Docker Containers. So everything is a-okay within the local area network. The trouble I run into is trying to access them remotely.

 

My first attempt:

Since everything was seemingly working well, my first reaction was to just forward some ports and everything would work. My setup is as follows:

 

ISP(my public IP, lets call it 123.123.123.123) <--> ISP provided modem/router combo (I'll call this router #1, subnet 10.10.10.XX) <--> My router (I'll call this router #2, with IP 10.10.10.400 on router #1 and subnet 192.168.2.XX locally) <--> Server (with IP 192.168.2.500)

 

So I proceed to forward some ports and no dice.

 

Thinking maybe there is something goofy going on with the port forwarding, for testing purposes (bc this is obviously a terrible solution), I DMZ 10.10.10.400 (the IP of router #2) on router #1, and DMZ 192.168.2.500 (the IP of the server) on router #2.

 

Again no dice.

 

Thinking there is still something goofy going on with port forwarding (potentially a double-NAT issue), I allow remote management of router #2 on port 8085 and go on to verify if I can do anything on router #2 by trying to access the router setup externally (from a device with a completely different public IP) by trying to connect to 123.123.123.123:8085. This works. I am able to change router #2 setting from the internet, externally. At this point this makes me think there is something going on internally within the LAN of router #2. Obviously, at this point I take away all the DMZs and revert back to port forwarding.

 

Attempt #2: 

Router #2 has some VPN client options. I setup DDNS on router #2 and I setup a VPN so external clients can log into that network with the help of DDNS. Once logged in, they get IPs in the range of 192.168.3.xx. Again, from the outside, I VPN in and verify everything is good by accessing other devices and also seeing if I can see router #2's dashboard by going to 192.168.2.1. All of that works (confirming there is no routing issue??), but I still get nothing when trying to access the server (either the Unraid dashboard or docker containers).

 

Attempt #3:

After reading a bunch more (because I'm stubborn and should've done this from the beginning)  I decide to try to setup Wireguard on the server instead of using the VPN client on router #2. I do so following the instructions at https://unraid.net/blog/wireguard-on-unraid except rather than installing a Wireguard app, I go directly to the VPN manager located under the Unraid settings. Essentially skipping step 1. Everything seeming goes well,  I activate Tunnel wg0 and I try to login from an external device. I seems like I connect, very small amounts of data show received and sent; however, I get no handshake and more importantly, I can't access the internet, the Unraid GUI, or any containers' GUIs. 

 

Miscellaneous Attempts: 

Using combinations of the attempts listed above along with random stuff I've found on this forum and elsewhere, I've also randomly changed the Peer type of access within the Peer options of Wireguard VPN Manager settings, I've changed each container's Network types, under the Docker settings I've enabled host access to custom networks, and I'm sure I've probably tried a dozen other things to no avail. 

 

So with all of that, can any of you guys point me in the right direction? It still feels like it's something small that I've overlooked related to the server not allowing connections from any device that is not on 192.168.2.xx.

 

Thanks in advance!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...