Jump to content

Default Routing Upon Reboot


Go to solution Solved by AtomZ,

Recommended Posts

Hi everyone - I am running into an interesting situation that I have a work around for but wondering if there is a permanent solution. -

 

I have a PCIe NIC card that is hardlined into my router/firewall for use for my VMs to separate that network traffic on its own VLAN. This is labeled as eth1 to Unraid on its own subnet. Eth0 is set statically on my main primary subnet for the main Unraid network/management interface.


Every time I reboot the server, the default routing table on Unraid gets set to the eth1 subnet and not eth0. To fix I have to disable docker and VM manager, set eth1 to none, which automatically switches the default routing to how it should be on the primary subnet, then I set eth1 back to how it should be and everything is fine.

 

How do I keep what I have working to stay on each reboot of the server? I’m hitting a wall, thanks for any input.

Link to comment
  • Solution

Alright I fixed it!!!!! - I learned something new today. It was probably simple to always know but never actually took the time to understand what the metric settings are for under network settings. Now I do. 

 

If you are running multiple physical NICs, and you want them to have to have their own subnet (I control this at layer 3) and also communicate out to the internet which requires a default gateway, you must set the metrics for your default gateways if you have multiple gateways for routing. 

So in my case - br0's gateway which is eth0 is set to '1' which takes the priority gateway for routing, br1 which is eth1 I set the metric for the default gateway setting to '2' which is the next default gateway but is not the priority gateway for Unraid. 

I hope this helps anyone in the future if they run into this and wondering why on reboot the default routing won't stay persistent if there are multiple default gateways in your system. 

 

Example:

image.png.b89b73d8d63d84081e211b89174e246d.png

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...