Jump to content

Lost Primary Share, Creating a share tanks my Server now. - 4.7 Pro [SOLVED]


Recommended Posts

I am currently using 4.7 Pro.  I'm a long time customer and am looking for some help to access my primary media share again.  I'll try to make this simple.

 

Before:

My original config had 1 media share of //tower/NAS/.  I maps all of my PCs to this share.  As expected, all of my data on all my drives are saved under this NAS folder.  

 

What changed:

I saved my config in a safe location and attempted to upgrade to 5.0.  In the process I lost my NAS share.  I reinstalled 4.7 and put replaced the info with my original backup hoping to go back to where I was.  This was not the case, still no share.

 

Now:

I have my original 4.7 installed, my configs all work except my shares.  NAS does not come back.  When I create a NAS share, it crashes my server.  First I lose the ability to access via web interface, then I loose the ability to access via mapped drive.  Also, when I do create the share via web interface, I can see the share on my PCs... but they show the share as being only 20MB, and I cannot see any of my old data.  The only way I can access my data is to look on each drive specifically.

 

What do I need:

I am looking to restore the share without having to back my 7TB worth of data off server and rebuild the array from scratch.  Can anyone help guide me?

 

Thank you,

PrescottX

syslog.txt

Link to comment

The syslog didn't show any errors. All the disks mounted OK and unRAID attempted to share any existing user shares.

 

As a first step, set the disk shares to export read/write. Go to the network and check each disk to see what it contains. Every disk (except maybe the cache) should have a directory called NAS with some of your data stored in it.

 

Peter

 

Link to comment

The data in every disk is okay and located in the NAS directory.  The problem is I attempt to recreate the NAS share and I get as follows:

 

1) My mapped shares "X:\NAS" are empty and show "0MB of 20MB free"  when they used to show about "3TB of 9TB free" and contained all my data.

 

2) Shortly after attempting to access the share to check for data, the server crashes in some way and must be restarted to access again.

Link to comment

I would make sure there is nothing left over on the flash from the other installations. Basically, compare the 4.7 download zip and the flash contents and delete everything extra but the key file. At the very least, clear out the extra contents in the config directory - you should find files for any shares you ever created and they can be deleted. If you have add-ons and you are positive they are OK then you can leave them in place.

 

If the disks contain the NAS directory then the NAS directory should automatically appear as a user share.

 

The other option is to save the key file and then delete everything on the flash drive. Place the contents of the 4.7 zip on the flash with the key file and then start over assigning disks and building parity. Once parity is built then you can turn-on the user shares.

 

Peter

 

Link to comment

Thank you very much lionelhutz!  I just rebuilt a key and assigned my drives, then let my parity check go through and I'm back up and running.  Thanks for such a quick response...  This is why I love this community, always someone out there to help in need!

 

Peace!

 

-Brandon

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...