Jump to content

[SOLVED] unRAID Disabled Drive, Now Wants to Rebuild


Recommended Posts

Hi,

 

I attached a screenshot that should explain my current situation, but I'll add some context as well. I was using my server yesterday and everything was going fine. I powered it down and powered it back up today. There was nothing being shared, so I looked at the GUI and found this. I don't know why it assumed the drive has been replaced, but it is acting as if there is a different drive in there.

 

I could just rebuild the drive, but I was wondering if there might be some underlying issue that I should take care of. Also, when I do get around to rebuilding it, is there a way to do so that won't take as long since it really is just the same drive and same information?

 

Thanks for you help. I'm not going to touch anything until someone can shed some light.

Multivac_-_Main.png.40a38e89d20191ebce80513e216fdab2.png

syslog.txt

Link to comment

For a drive to be disabled, a "write" to it had to have failed.

For a drive to be identified as "new" the array had to have been booted when that disk was not recognized by the "bios" as being there.

 

It sounds as if the drive had already been disabled, and booted with it missing (bad power connection perhaps)

Now, the disk is responding once more, and it needs to be re-constructed.  If it was disabled, a "write" to it failed, so it is guaranteed to be out of date.

Let the array re-construct it onto itself.  As you said, most of what it is writing is already there, but the one "write" that failed is not... so it needs to be re-constructed.. and it will by the time the re-construction is finished.

 

Joe L.

Link to comment

Alright, will do. Thanks.

 

As far as the power goes, it makes sense that a gap in the connection to the drive would be the source of the whole mishap, but I'm not sure how it would have happened; I checked the power connection and everything looked fine. I'm wondering if it could have been caused by a bad SATA connection. Interestingly, it is the first and only drive I have attached to the SATA expansion PCI card I recently put into the server. Everything looked fine there, too, though. I have a 500W psu, which I'm assuming is enough to run the 5 drives and 2 pci cards (gigabit network card, and SATA expansion card).

 

And now that I think about it, I remember that the last thing I moved onto the server (a video) seemed to go over just fine. I remember copying it to the server and then watching it immediately afterward. Would it be possible for it to have copied onto parity while the disk was "missing"?

 

Either way, I'll be rebuilding the drive overnight. If everything goes fine, I'll change post to [sOLVED].

 

Thanks, again.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...