Jump to content

Trust My Array Procedure - MDCMD not found?


revco

Recommended Posts

Hello,

 

Running 4.7AIO, fairly new to unRAID.

 

I was rearranging some drives tonight (partly for practice, partly because I wanted to organize some drives) and I ran into a problem with the Trust My Array procedure.  First, I was following the steps to physically move/reassign drives here:

 

http://lime-technology.com/wiki/index.php?title=FAQ#What_is_the_safe_way_to_rearrange_disk_numbers.2C_assignments.2C_slots.2C_etc.3F

 

All was well, but when I restarted the server, I received "Invalid configuration" and it showed my move as missing, even though I had reassigned it elsewhere.  No problem, just gotta Trust My Array because my parity check was solid prior to making these changes.  So, I followed this procedure because I was confident my array/parity were good post-move:

 

http://www.lime-technology.com/wiki/index.php?title=Make_unRAID_Trust_the_Parity_Drive,_Avoid_Rebuilding_Parity_Unnecessarily

 

Ran the initconfig, blue balled as expected.  But then, tried to run the following to cause the server to trust my parity:

 

mdcmd set invalidslot 99

 

Here's what happened:

 

root@gaia:/boot# mdcmd set invalidslot 99
-bash: mdcmd: command not found

 

Not a big deal, I just restarted the array since that step was technically "optional" anyway...but I'm not happy that I now have to rebuild my parity because for the time being I'm unprotected.  I checked my flash (both in Windows and Linux) and sure enough, mdcmd doesn't exist in boot or anywhere on my flash drive.  I downloaded a fresh zip of unRAID and sure enough, mdcmd doesn't exist in a fresh download either.  Am I missing something?  Is the "Trust My Array" procedure no longer valid in 4.7?  Apologies if this has been answered elsewhere, but I've searched for the answer and haven't seen someone hit a problem with trusting the array, except in 5.x betas.

Link to comment

Derp.  I should know better than to do something like this when I'm tired after a long, long week.  I found my mistake.

 

/root

 

NOT:  /boot

 

Technically, it's truly in /root.  Apparently I didn't see that little part in the instructions that said, "just type cd dork."

 

I'm feeling completely retarded at the moment.  Nevermind me and my ineffectual eyeballs.  I'm still getting used to running Linux in memory.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...