Jump to content

[SOLVED] mysql databases gone on reboot


love2cad

Recommended Posts

Hello,

 

I seem to be having a problem with my mysql install on my unRAID server. I just spent 3 hours setting up two machines for a XBMC centralized connection. When I was all done and about to head to bed I restarted the server. After the reboot it seems that the re-installation script over wrote my setup. While the databases are intact on my data drive /mnt/disk1 they are not listed when I log into mysql via the terminal. I'm guessing the 'reinstall on reboot' has something to do with this. So, I have two questions...

 

1) How do I get the mysql server up and running when the system reboots without overwriting everything?

2) How can I push my databases back so that the connect works again?

 

additional info: I have installed mysql via unMENU and have it set to reinstall after reboot. I have my databases are located on my array at /mnt/disk1/mysql.

 

Thanks!!

Bobby

Link to comment

Solved... I found this code from liguidkaos and it did the trick... thanks..

 

#!/bin/bash
# Start the Management Utility
/usr/local/sbin/emhttp &

# Start the array
echo "Starting the array"
sleep 5
/usr/bin/wget -q -O - localhost/update.htm >/dev/null
/usr/bin/wget -O - --post-data 'startState=STOPPED&cmdStart=Start' localhost/update.htm >/dev/null

# Wait for disk1 of the array to come online
while ! test -d /mnt/disk1;do sleep 5;done;sleep 5

# Start unmenu
/boot/unmenu/uu

# Start Addon Packages
cd /boot/packages && find . -name '*.auto_install' -type f -print | sort | xargs -n1 sh -c

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...