Jump to content

LSI 9240-4i -> LSI9211-8i IR firmware: end of years of pain!!!


Recommended Posts

Hi folks, I'm new to this place (I don't use unRAID, don't kill me... :D) and I'm here to THANK YOU and to report my experiences for other users of this card.

 

I bought an ORIGINAL  (:-\) LSI 9240-4i card in 2010 and I've paid it... ehm... "a lot"...  :-\

 

I bought it since I wanted to build a fast RAID0 of SSDs and knew about the speed limits of AMD SBs...

 

At first I installed it on my Asus mainboard with "conventional" BIOS and it worked flawlessly. Then my mainboard died and I changed it with the *NEW* Asus Sabertooth 990FX (rev.1) provided of one of the first UEFI BIOSes.

 

The first BIOS of this mainboard was an "hybrid": it had the "cosmetic appearence" of UEFI BIOSes BUT it loaded Option ROMs *after* POST, like conventional BIOSes did. This BIOS was like a pre-BETA, quite an "ALPHA", full of bugs and quite unusable. But my LSI 9240-4i liked it.

 

When I upgraded to the mainboard second BIOS release (a "real" UEFI one this time, with "Option ROMs loaded *before* POST...) started all of my issues.

 

My LSI9240-4i was able to work only with Win 7 x64 between OS of my interest and only with *some* of the firmwares released (I've tried tens of that... ::)). This after resetting itself one or two times (the LSI card) during boot since "fatal errors" - as reported by MSM log - so the boot operations required *minutes* to be terminated (haven't I bought it to have a faster system?  ::)).

 

On Windows XP it started to BSOD 0x0000007B if booted from RAID array or driver error "Code 10" if booted from another disk (same thing...). This happens in Win 7 x64 with some of the firmwares (like the latest one of 2015... YES, after five years they are going worst instead of better...  ::)) too. Different drivers versions don't change anything.

 

All Linux live(s) and Linux live based ISOs (like Acronis, Paragon, etc...) hanged during boot when loading megasas driver too...  :-\

 

I've tried obviously all the possible combination of BIOS settings and versions, firmwares, installing in 1st slot, in 2nd, in 3th, in 4th, disable all, enable all, etc... no way.

 

I've so contacted LSI support (sic!  ::)) and they weren't able to find a solution if not saying to me that I have installed the card on a "not certified mainboard".  >:(

 

I "kindly" explained them that PC world doesn't work "on certified parts" BUT on standards and compatibilities and that if their (mine... I've paid for it!) card worked only on some mainboards, they should have stated it clearly on the box!  >:(

 

Then, anyway, they put it on "testing list" and after some months, it has been added on compatibility list!  :o

Yes, my rev., my BIOS version, mine! But mine haven't worked fine a single day with the LSI card with the exact firmware they declared to have tested!!!!  ::)

 

So... no cigar until these days. I wanted to upgrade disks of my system and didn't want to do it on a bad working card which boots a single OS and requiring minutes on SSDs to do it...

 

Since the new Avago brand seemed to have bringed new "enthusiasm" in LSI with a lot of new firmwares and drivers released in latest months, I decided to try latest firmware (some of the changelog talked about fixing issues of BSODs on UEFI mainboards...).

 

Result? BSOD even on Win7 x64.  ::)

 

I have contacted their assistence again... a lot of tests requested to me, a lot of promises... but when nothing worked, they ... vanished again with my ticked "Closed"!  >:(

 

I was sure it is an issue related to *when* the Option ROM is loaded, if before or after POST, so I decided to search for possible solutions...

 

I've found that some mainboards have CSM related settings in BIOS that seems to address this issue (something like "Load Option ROM in Legacy or UEFI Compatible mode"), but Asus has added this only on Sabertooth FX990 R.2 while mine hasn't this setting even in latest BIOS! (Thank you Asus!  >:()

 

So, at last... I dunno how... I've found this thread...  :o

 

Crossflashing a firmware of another (different...) card on mine seems a bit strange at first but more I red and studied about it, more I was of the idea that it could even address my issue too!  :P

 

At first I've not well understood differences between IR & IT firmwares, and why I should have flashed a 9211-8i firmware and not the 9211-4i since I have a -4i board (to explain to all: 9240-Xi cards are all based on LSI SAS2008, while 9211-Xi cards are based on LSI SAS200X, with -4i so based on LSI SAS2004 and only the -8i based on mine LSI SAS2008...).

 

Then it became all clear: I need RAID0 and boot option, so I eventually need to go with IR firmware with ROM BIOS installed too.

 

When I started to read installations guides and downloaded from LSI firmwares and drivers what I at first realized was that the LSI team of developer of HBAs is very different (and works in a *very* different way...) from the MegaRAID one... I 've found them a LOT more professional and sharp than MegaRAID ones.

 

Moreover, I saw that Option ROM of 9211s was, even in IR "flavour" a lot simpler and smaller than 9240s one. But the only "important" feature I would have lost of 9240 was RAID5 (which doesn't interest me on this PC and that, anyway, 9240s cards are very slow to manage...).

 

So, before go Areca ($$) and put my 9240 in the place where it deserved to rest (the trashcan...  >:() I decided to go Crossflashing!!!

 

I follow the procedure indicated and flashed to P11 IR at first. I've done it on a standard BIOS mainboard (a cheap AsRock...) to not have "PAL issues" and because of problems I've already had in flashing it on my Sabertooth (with flashing operations which gave back errors in middle of the process and I who sweated because of this...  :-[).

 

I have gone with a bootable DOS USB stick and all went flawlessly!

 

On that board I had problem in entering in card BIOS with CTRL-C (probably because I had the USB stick still installed, I'm not sure...) but since I've installed it in my system it worked like a charm!  :P

 

"Obviously" it wasn't able to recognize my old array (no foreign array available...) but I was expecting this since I've understood that the two products lines were developed by different teams... but it wasn't a big issue since I've always backups and, anyway, I've Windows to recognize the new card before it could be able to boot from the RAID array (otherwise it goes BSOD...).

 

Fixed these "small things", when I first started my installation I found it very fast and responsive!  :o

 

Some benchmark confirmed it: over 80 MB/s faster on sequential reads on same disk array! Nice!  :P

 

Moreover: no more BSODs or boot hangs on any OS!

 

So... THANK YOU again folks!  ;)

Link to comment

I don't know how this board opened a new topic for my previous reply to thread, but I'm sure Moderators could eventually fix this...  :-[

 

What I would like to explain in this post is PROs & CONs I've found crossflashing a LSI 9240-4i to 9211-8i IR firmware... I think it could be very interesting for who is thinking to do this step...

 

PROs:

- card more (totally?) compatible with mainboards with UEFI BIOSes;

- a bit faster on accessing RAID0 arrays of same disks;

- card drivers natively included on all most of Windows versions from Win2003 to Win10 or Server 2012. This is *very* usefull on installing and/or repair Windows installations without the need to load "Certified drivers" first...  ::)

(this doesn't happen with 9240s drivers);

- card drivers natively included/supported on most of Linux lives & distros and on Linux based disk management ISOs (like Acronis, Paragon, etc...) with most of them capable of seeing RAID drives like them were simple "single IDE drives" and correctly manage them (even ISOs like EaseUS Partition Manager who declares to be not compatible with RAID...!)

(this doesn't happen with 9240s drivers);

- single drives showed directly to OS in "pass through" mode (and able to boot from them too...), without the need to configure them as JBOD as required on 9240s;

- faster disks recognizing during Option ROM boot;

- onboard BIOS doesn't require mouse to be used;

- onboard BIOS has some "compatibility settings" available to resolve possible issues;

- possibility to disable BIOS at all if not booting from RAID array, speeding up booting timings;

- more professionally developed firmwares, drivers and manuals/documentation (IMHO...  :P)

- card "modular software" with BIOS, firmware and UEFI modules which could be flashed indipendently from each other;

 

CONs:

- no RAID5 support (even some 9240s don't have it "out of the box"... and anyway writing performance are horrible...);

- only 64KB stripes available on RAID0 (9240s have 32K to 128KB options);

- some less options/functions for virtual drives (and card) available in MSM;

- less user friendly onboard BIOS, not "Windows based" as 9240s one;

- unable to flash firmware directly from MSM (there is the option but it seems not to work...), only from CLI. Anyway is possible to flash firmware from CLI box on Win7 x64 (and some other systems): I've upgraded from P11 to P19 that way on UEFI mainboard flawlessly;

- need to rebuilt arrays after crossflashing since 9240s arrays aren't compatible with 9211s ones;

- LSI MegaRAID team wouldn't probably agree with me but... I don't see more significative CONs..!  ;)

 

Anyway, until they wouldn't be able to develope a good working firmware for this card, I'll go 9211 all the life!  ;D

 

P.S.: since I saw somewhere that there is somebody here who is "collecting" all the SBRs and I haven't still seen the "original" LSI 9240-4i posted here... I'll attach to this post!  ;)

9240SBR.zip

Link to comment
  • 4 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...