[Solved] Share reports only having 410GB free when that's only what is used

Recommended Posts



I have a share, with what the share page reports having 410GB free, with the following configuration:


Name: crashplan-backup


Allocation method:

Minimum free space: 400GB

Split level: Not set - split function not used

Included disk(s): Disk 9

Excluded disk(s): None

Use cache disk: No

Share empty? Yes


Disk 9 Hitachi_HDS5C3030ALA630_MJ1321YNG0MR1A (sdn) 25 °C 3 TB

Used: 439 GB

Free:  2.56 TB


When I go to the share via shell, and try to create a folder, this happens:


root@Tower:/mnt/user/crashplan-backup# mkdir test

mkdir: cannot create directory `test': No space left on device


It sounds like this should be something obvious. I have stopped, rebooted, and started the array to no avail.


I was not able to create the share simply by using the settings above. For the share to successfully be created, I had to create it with all disks included, then remove the disks I did not want to include.


Here is the output when I tried to create it directly to disk 9, originally.


May 20 11:43:39 Tower avahi-daemon[8727]: Service "Tower-AFP" (/services/afp.service) successfully established.

May 20 11:45:25 Tower emhttp: shcmd (15613): mkdir '/mnt/user/crashplan'

May 20 11:45:25 Tower shfs/user: shfs_mkdir: assign_disk: crashplan (28) No space left on device

May 20 11:45:25 Tower emhttp: _shcmd: shcmd (15613): exit status: 1

May 20 11:45:25 Tower emhttp: shcmd (15614): rm '/boot/config/shares/crashplan.cfg'


It clearly doesn't like disk 9. I currently have the disk shared directly and can back up directly to the drive through AFP. But if I want to create a share and use it that way, no luck.


Here are the current contents of disk 9:

root@Tower:/mnt/disk9# ls -la

total 12

drwxrwxrwx 11 nobody users  400 2016-05-20 12:19 ./

drwxr-xr-x 14 root  root    0 2016-05-20 11:36 ../

drwxr-xr-x  2 root  root  304 2016-05-20 12:03 .AppleDB/

drwxrwx---  2 root  users  72 2016-05-20 12:03 .AppleDesktop/

drwxrwx---  2 chris  users  168 2016-05-20 12:03 .AppleDouble/

drwxrwx---  3 root  root  112 2014-10-08 17:57 .TemporaryItems/

-rw-rw----  1 root  root  4096 2014-10-08 17:57 ._.TemporaryItems

-rw-rw----  1 root  root  4096 2014-10-08 17:57 ._.apdisk

-rw-rw----  1 root  root  291 2014-10-08 17:57 .apdisk

drwxrwx---  3 root  users  80 2016-05-20 12:03 Network\ Trash\ Folder/

drwxrwx---  3 root  users  80 2016-05-20 12:03 Temporary\ Items/

drwxrwxr-x  3 root  root    88 2014-09-20 12:28 crashplan-backup/


du -h : 410G


Any assistance is greatly appreciated!




Link to comment

After all that, I discovered that under the Settings/Share Settings, some time ago I had not included Disk9 in the list of available drives for user shares.


Unfortunately, the share page does let you create shares for drives that are not included in sharing but then picks disk1 as a default for a usable share.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.