Jump to content
DoItMyselfToo

ssl certificate provisioning w/ pfsense (aka logging in to local unraid server via ssl)

1 post in this topic Last Reply

Recommended Posts

provisioning continued to fail, even after entering the custom option in pfsense dns resolver.  finally, i had the idea to log out of pfsense and then log back in again.  after doing so, provisioning completed successfully.

 

i spent a good amount of time setting up ssl login on my unraid server.  after searching the unraid forum and not finding a solution, i was able to get provisioning to finally work.  the main thing with everything else set correctly was logging out/in of pfsense (above).  so i thought i should share this.

 

here are the steps to setup provisioning on your unraid server with pfsense as your firewall/router:

 

Static ip/dns in unraid:

1. click on "settings" tab.

2. turn docker off by clicking on "docker" and setting "enable docker" to NO, and then click "apply", then click "done".

3. turn vm off by clicking on "vm manager" and setting "enable vms" to NO, and then click "apply", then click "done".

4. click "network settings" and check the following:

 

     ipv4 address assignment:        <set this to "static" after the other settings are confirmed as follows>

     ipv4 address:                          <should be the local ip address of your unraid server>

     ipv4 default gateway               <should be the ip address of your pfsense router>

 

     ipv4 dns server assignment:            <set this to "static" after the other setting is confirmed as follows>

     ipv4 dns server                               <should be the ip address of your pfsense router>

 

Provisioning:

1. in unraid go to "settings" tab.

2. click on the system settings "identification".

3. be sure that "use ssl/tls" is set to AUTO.

4. then login to pfsense.

5. go to "services" then "dns resolver".

6. scroll to the bottom of the screen and click on "display custom options".

7. in the custom options box type or paste the following:

 

server:
private-domain: "unraid.net"

 

8. click save.

9. click apply.

10. log out of pfsense.  then log back in to pfsense again.

11. in unraid go to "settings" tab, then click on "identification".

12. scroll down the page and click "provision".

 

Edited by DoItMyselfToo

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now