Jump to content
Sign in to follow this  

Flash Replacement on old 4.x server

1 post in this topic Last Reply

Recommended Posts

What I did when I finally had a FLASH drive die on me on one of my unraid servers.


  It was in March 2019, and my main unRaid server, or is that Unraid now..., died.  I tried a couple times to reboot it, and removed power from the power supply and pressed the power button to drain the power supply, wait 10 minutes, everything... but nothing I did allowed me to turn the server back on.


  OK, I guess the power supply may be bad, or I finally had a motherboard/CPU die on me.  No big deal, just time to replace the bad parts.


  I look at my Plex server and see that I also seem to be having some issues with one of my other Unraid servers.  OK, probably just a reboot to clear cache memory, as I think it does not have much RAM, and it has been a LONG time since a re-boot, even though I do not ever remember having a problem with that server before.  I open up a web browser and also a file manager window on one of the networked computers upstairs, where I live to look at the Unraid server in the basement.  Then I see something that at the same time makes me curious, and a bit nervous; I see NO FLASH drive on the server.  I try to re-boot from the main web console, (NOTE THIS IS a server running a PRO license on version 4.5.3, as is the prior listed server that will not power up.)  The server does not respond as expected, and does not even want to shut down remotely.


  At this point I am getting a bit more concerned.  This second server is not my main server, but is I would describe as my third priority server, PLUS it contains multiple backups, and archives of retired sets of video files, that were replaced by, or are master and uncompressed copies, from my TV and Movie collection.  It is also the server I use for "work" storage, files I am in the middle of processing and organizing before I finalize them and add them to my Plex library for my family to access.


  I walk down the stairs, and find that a reboot at the computer only yields a message that a boot device can not be found.  OK, no big deal, I have had to change boot devices before on this computer, since it seems to like to re-arrange boot order on hard drives (the USB FLASH is treated as a hard drive on this computer) sometimes with a power off after a power outage.  The next problem I run into however is not normal.  I am unable to see the USB Flash drive to select it to boot from!


  I take the flash drive and plug it into a few more computers, all with the same result, THEY DO NOT SEE IT!  It is just as if I am not plugging the drive in at all!  Absolutely NOTHING!


  It looks like it is time to replace my old trusty 2GB Sandisk Cruzer.  I know there is no problem getting a replacement key, as that was my first concern years ago, that I wrote an email about before buying my first license, and received a nice reply about how I would just need to write an Email if I ever had a Flash drive fail on me, and include the GUID of the new flash drive as well as order details of the original being replaced.  So I have never worried about it.  Since then, there now is a very nice automated key replacement method which makes life even easier, and quicker.  But, remember I am still using this flash with an much older version of Unraid, 4.5.3, that has no such method for automatic on-line replacement.


  OK, this server is taking over now for repair priority, the main server will just need to wait.  For details on the main server repair see this post;


  Here are the details on this server.  With the Flash Drive that failed, and has now been replaced...

  It is an old SuperMicro server that had been retired I got for a great deal a few years back.

OS at time of building: Unraid 4.5.3
CPU: AMD Dual-Core AMD Opteron(tm) Processor 2212 HE
Motherboard: SuperMicro H8DME-2 REV 2.01 
Case: SuperMicro SC846 series 
Drive Cage(s):  stock - part of case chassis 
Power Supply: stock - 2 ea redundant configuration 
SATA Expansion Card(s): 3 ea SuperMicro SAT2-MV8 PCI-X cards
Cables: stock 
Fans: stock 


Parity Drive: WDC_WD20EFRX 
Data Drives: 2ea WDC_WD10EACS, 1 ea WDC_WD1000FYPS, 1 ea TOSHIBA_DT01ACA2, 1 ea ST2000DM001, 2 ea WDC_WD20EFRX, 1 ea WDC_WD2003FYPS, 1 ea Hitachi_HUA72302, 4 ea HGST_HDS724020AL, 2 ea Hitachi_HDS72202, 2 ea Hitachi_HUA72202 
Cache Drive: -none- 
Total Drive Capacity: 31 TB, 18 of 24 bays 


Drives Outside of Array: 1 ea Hitachi_HUA722020AL, 1 of 24 bays


Primary Use: Backups and temporary work space 
Likes: Nice and reliable 
Dislikes: Takes a LONG time to boot 
Add Ons Used: unMenu, Preclear 
Future Plans: Add more drives as needed till full only 5 bays open (which will also need an update to 6.x)  


Boot (peak): -not measured-
Idle (avg): -not measured-
Active (avg): -not measured-
Light use (avg): -not measured-










  Since I did not want to wait for a replacement Key for my new USB Flash Drive, I decided to download and boot a new copy of Version 6.x Unraid.  That way I would be able to get a replacement key quickly via the web interface.  I had never done this before, but I was sure it would be quick and easy, which it was!  The only concern I had was I was not sure if a new key would also work with older versions of Unraid.  My replacement key does however.

I am still not sure if a brand new key would or not, but I think it likely would work, but I doubt anyone will buy a new key to use on old 4.x Unraid either.


  I followed the procedures to install 6.x on a new Flash drive, using the V.1.5b USB creator under Windows.  I did make a couple USB drives, one with the Stable version download option, and one with the local ZIP FILE option.  I was a little surprised that only the download option allowed for the feature to customize the install.  But this was not of concern, and i can see that if you are making a new key from an archived ZIP you wish to duplicate, that the option to customize may not really be wanted then.


  I then plugged the new USB Flash into the server, without remembering if the hardware was even new enough to run 64-bit, but it was, and I was able to set the BIOS for booting, and booted into the new 6.X world on this old server with no problems.  Of course I was in TRIAL mode, with no new key yet, and my drive array not yet mapped.  I then copied my backed up key for my dead USB flash drive to the Config directory on the root of the new USB Flash drive.  Rebooted and was then presented with the invlaid key message and ability to replace the key on-line.  A real good place for the steps to follow is here;




  Though I did not really follow that guide fully, the steps are basically the same.


  I did however walk through the process to request a replacement key, and was then able to intall the new key to the new flash within just a few more minutes.


  I re-booted again to make sure everything was working, and that all my drives were there, and undefined in Version 6.x  This way I knew all was good up to this point, and that I could also update to Version 6, in the future, or if I needed to now if the following steps to go back to 4.x failed.


  This is when I ventured back in time, hoping my new key would work with my old 4.x version I had been using.  I am pretty good with backups, and with periodic directory captures of my systems.  Not as often as I should probably, but not bad.  I did have MOST of the contents of the old flash drive backed up, since I had long ago created a automated process to create a new USB flash from install files of for unRaid 4.5.3, which most of my servers are running.  It even sets the Go script, and copies over preclear and unMenu so I have everything needed for a new server...  I just never thought about a rebuild of an old server before.  OOPS!  No backups of my configuration files I was running.  NO backup of the cool image of the server used in MyMain.  This picture, I will maybe worry about in the future, maybe not.


  I put 4.5.3 on the new USB Flash drive, edited the ident.cfg in the config directory with the correct server name, and kept the new Key in the config directory also, rebooted and I was able to see my server running again under 4.5.3, and properly licensed as PRO!  Of course I needed to change the drive mappings and then I would be ready for Parity rebuild!


  If I just was using user shares, it would have been easy, but I use Drive Shares, AND user shares depending on the need. (Warning be careful as always in this situation as data CAN AND WILL be lost if you copy from one type to the other! - YOU HAVE BEEN WARNED)  I needed all my data on the same drives as they were before to keep everything working properly in my network.  I pulled up my most recent directory tree listing of my drives, and it was able to help with all but the 5 newest drives.  The last 5 drives I needed to do a little more work looking at my PLEX server mappings, and my compression tools configurations.  Note that my PLEX server is on a separate computer with access to all three of my main unraid server shares.  From there I was able to see exactly which drives should be mapped to which unraid drive slot!  :-)  I mapped them verified everything on the network was again full functional that used resources on this server, and that all media was properly in place on PLEX for this server.


  I then stopped the unraid server, enabled parity, brought the server back online and started a parity build.  The end result is that everything is now working again on this server, which then allowed me to move back to getting the main server running again, (see above link for that story)


  Maybe I should look at adding a second CPU and memory to this server.  Probably would be really nice if/when I upgrade this to 6.x of Unraid.



Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this