Struggling with single gpu passthrough

Recommended Posts

Hello everyone! I need help! I spent days unsuccessfully trying to passthrough a single gpu to an Ubuntu or libreelec vm. The host I have is:


- Supermicro x11ssm-f

- Xeon 1235L v5.

- 2x4tb wd hdd data/parity

- 1x1tb ssd for vms (not cache drive).


I tried following cards: Asus gt520, EVGA gt740 SC, sapphire hd5770. They're all old and the best I could achieve is with 740 to show Ubuntu 18.04 gui and then within a minute it shows artifacts and hangs. I went through numerous vm configs, vbioses, YT how-to videos, this forum and I start to lose hope making it work. Vm OS works well in vnc, shares work well... But I'm trying to build nas+htpc in one box. Please help!


Edited by unruly
Link to comment

Thanks Mark! I watched them all and followed. I'm wondering if my cards are old and not supported, or is it old cards plust latest unraid version, or combination with Supermicro MB? The tutorials you've posted are awesome and straight forward, but I just can't make it work in a stable way... Possibly missing some obvious stuff or just fighting unknown incompatibility. Wondering if anyone using this old gpus with current unraid version?

Link to comment
  • 5 weeks later...

Just to provide an update that others may find useful. I could not make GPU passthrough into ubuntu 18.04 for Nvidia GT520, GT740 and ATI HD5770 cards. All the cards hanged unraid. I was able to make to passthrough GT740 (EVGA, using exactly the same bios file as in ubuntu case) into Win10 half-successfully: VM starts successfully, Windows identifies and uses the video card through HDMI, I can restart the VM as many times as needed. The only issue I have is that HDMI audio does not work. :( Would appreciate if someone saw this issue: In VM config in unraid it sees the audio controller as NVIDIA GK107 HDMI Audio Controller. When in Windows, in NVIDIA control panel, It sees my receiver (Pioneer) connected to HDMI but has no HDMI Audio device in device manager and no devices in the playback devices in sound config. My motherboard in X11-ssm-f if it helps. I tried to reinstall drivers, switching on tv, reciever and PC is different order -- no difference. Video works 100%. HDMI audio does not. Halp! :)


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.