Jump to content
  • Well, that was a mistake :) 6.12.7-rc2 upgrade

    • Minor

    TL:DR - I updated my server from 6.11.5 and now Docker won't recognize my eth4 VLAN (containers don't show it as an option, not showing at bottom  of network settings, but DOES still show as an option in Docker settings).  I tried deleting it and readding and it didn't help, and so I started a downgrade with the "improved" GUI, which only gives 6.12.4 instead of the prior version (6.11.5).  Now it isn't booting, FML.


    Background - Ihave 3 Unraid servers, 2 on 6.12.6 and one 11th gen Intel I've had to keep on 6.11.5 due to instability on 6.12.x.  It's macvlan for Docker and even removing the bridges from eth0 and switching to ipvlan hasn't fully fixed it in the past.  Decided to try ipvlan again today and rebooted/restarted just fine, as it has before.  Did the upgrade and game over.  Unfortunately the other 2 continuing to be good on 6.12.6 and the security updates mentioned in 6.12.7-rc2 prompted me to make a bad call.


    I don't have the diagnostics because of the way this unfolded.  Just wanted to report it.

    User Feedback

    Recommended Comments

    Okay, so happy to report that after a hard power cycle I was able to get it to boot.  I was surprised to see that despite it saying it was going to take me down only to 6.12.4 it did in fact restore me to 6.11.5. 


    The bad news is since it updated my CA plugin it now won't load it because I'm not on 6.12.x, but I was able to paste the URL in for the 9.30.2023 version to get it back.


    Anyone got ideas oon how to work my way out of whatever the heck happened to my networks and Docker configs during the upgrade?  I just tried going to 6.12.6 first and it has the same problem.  I'm guessing, as I've attempted this before, that if I leave it macvlan and do the upgrade it would work, then maybe I can try to switch to ipvlan, but the whole thing smacks of some sort of issue with the migration script.

    Edited by BurntOC
    Link to comment

    UPDATE - Nope, switching to macvlan to do the update still results in Unraid acting like that eth4.40 interface isn't there.  I'm sure if I turned bridging on the interface it would show up, but I didn't have to do that before so....

    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Status Definitions


    Open = Under consideration.


    Solved = The issue has been resolved.


    Solved version = The issue has been resolved in the indicated release version.


    Closed = Feedback or opinion better posted on our forum for discussion. Also for reports we cannot reproduce or need more information. In this case just add a comment and we will review it again.


    Retest = Please retest in latest release.

    Priority Definitions


    Minor = Something not working correctly.


    Urgent = Server crash, data loss, or other showstopper.


    Annoyance = Doesn't affect functionality but should be fixed.


    Other = Announcement or other non-issue.

  • Create New...