Webterminal interprets ^C as <ret>?

Recommended Posts

I just executed a command I very much did not want to execute, because it turns out that for some reason ⌃C gets interpreted by the Webterminal’s shell as a ⏎, even though


NAS# stty -a
intr = ^C [...]


is this a known issue? I’ve tried it on different devices and it seems to work this way on all of them. I’ve never seen this before on any Linux distro; universally (until now) I’ve found ⌃C aborts the current command and gives you a new clean command line, it doesn’t execute it!


Can anyone shed light on what’s going on? Can this be worked around (`stty` was already set correctly as I wrote, but altering it didn’t seem to matter)? Should I submit a bug report?


(addendum: I just tried other commands that tell me what the shell is seeing when I press ⌃C, and it’s seeing a ⌃J. But ⌃J and ⏎ (aka ⌃M) also send a ⌃J. Sooo.... weird.)


(This is on 6.9.0-rc2.)

Edited by TreyH
add’l info
Link to comment

That is not what I am seeing:



Now, I am in the USA and using the standard keyboard mapping for that country using a WIN10 PRO client.   You need to give us a bit more info about your client setup.


By the Way, <Crtl-J> and <Crtl-M> and <Enter> keystrokes all give the expected behavior on my setup.

Edited by Frank1940
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.