Jump to content

[Solved] Problems following the 6.9.1 upgrade


Recommended Posts

Hi there ! :)

Yesterday i finally was abble to upgrade to 6.9.1 (from 6.8.0) and since, there's persistant errors 😢

 

First thing : VM

Just after the upgrade, the VM Manager crashed and i was giving a "could not launch" error in VM tab

> After restoring a 2days old backup of libvirt.img and a reboot, i got back the VM tab and my main system "kind of" launch

"kind of" because it's slow, much more than before, and it's freezing. Sometimes i can stop/start the VM in unraid's GUI and i'm up again, sometimes it's freezing even unraid and no response at all (i have to force an unclean reboot with the tower's button).

 

Second thing : Docker

Since the upgrade, pretty much all docker run fine, except one, the more critical : Nextcloud

At first i had "just" an internal server error, but after some reboot (to bring back the VM part), the docker's not accessible anymore, i just have a page "connection failed". But it pings ok.

 

Third thing, on the system logs, i have a hell lots of :

Apr  5 13:10:17 Tower kernel: pcieport 0000:40:01.3: AER: can't find device of ID0000
Apr  5 13:10:17 Tower kernel: pcieport 0000:40:01.3: AER: Multiple Corrected error received: 0000:00:00.0
Apr  5 13:10:17 Tower kernel: pcieport 0000:40:01.3: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Transmitter ID)
Apr  5 13:10:17 Tower kernel: pcieport 0000:40:01.3:   device [1022:1453] error status/mask=00001100/00006000
Apr  5 13:10:17 Tower kernel: pcieport 0000:40:01.3:    [ 8] Rollover              
Apr  5 13:10:17 Tower kernel: pcieport 0000:40:01.3:    [12] Timeout        

who fills up the system logs :/

> For this one, i read this post :

And, following the answers, do a firmware upgrade (i have an x399 taichi that was on 3.80 firmware, so updated it to 3.90).
After this upgrade, i had to redo the virtualization options that was completely lost. Recovered the IOMMU group in unraid ok, rebooted but... vm/dockers and logs still the same.
There was a second thing i could try : append pci=nommconfto to syslinux.cfg, done and... still the same 😭

 

So, before restoring the 6.8.0 unraid, i'm asking if someone know what's going on and maybe explain it to me please :)

I'm attaching the diagnostic file and Nextcloud docker's log.

 

Thank you very much ^^

tower-diagnostics-20210405-1346.zip

NextcloudPi Logs.txt

Edited by AinzOolGown
typo+logs
Link to comment

Okay, responding to myself ^^

 

All up and running again after some sweating.

Docker> Deleted docker.img, redownloaded the apps and bam !

VM> Corrected the XML, for some reason it changed itself (maybe it's linked to the fact i played a bit with the graphic cards in between the upgrade)

 

And the AER error things was apparently caused by a PCIe riser from Corsair, replaced it with a ROG riser and no more errors

 

Thank you anyway ;)

  • Like 1
Link to comment
  • AinzOolGown changed the title to [Solved] Problems following the 6.9.1 upgrade

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...