Jump to content

Nvidia GPU Passthrough with vbios - No Display with VM's (System Log and Diagnostics Attached!)

Recommended Posts

Hey hows it going, my name is Tom. I've recently started using Unraid because it is the best solution out there for running a Media Server, File Storage and Virtual Machines.


I've tried all kinds of fixes and watched every video SpaceInvaderOne has made about Nvidia GPU passthrough, vbios dumping and I've still got no display output. I was using legacy boot which was working okay for Unraid but the graphics on the GUI mode was a bit out of whack, so i started using UEFI boot and that sorted out the graphics on the GUI Mode and normal boot mode. Just still no GPU Passthrough with VM's.


What's strange is that Unraid can boot into GUI Mode just fine using the GPU in slot 1, but won't passthrough on a Windows 10 or any other type of VM.


When starting up a VM (Win10 in this case) bellow is the error im getting on the log. (Screenshot also attached)


This is the error code in the log (Log Screenshot Attached)

2021-04-05T18:23:12.073130Z qemu-system-x86_64: vfio_region_write(0000:2b:00.0:region3+0x111d780, 0xccff0000ccff,8) failed: Device or resource busy

2021-04-05T18:23:12.074649Z qemu-system-x86_64: vfio_region_write(0000:2b:00.0:region3+0x1121708, 0x0,8) failed: Device or resource busy


Unraid 6.9.1

Motherboard: MSI Tomahawk b550 (MS-7c91) Version 2.

CPU: AMD Ryzen 5600x 6-core. (No On-Board Graphics)

GPU: Nvidia GeForce GTX 650 ti. (Slot 1)

RAM: 16gb DDR4 3200mhz.

Latest Bios Installed!


I've tried both types of vbios (Hex editing and Script in unraid)

All IOMMU Groups passed through successfully and i can boot into GUI Mode! 

IOMMU groups enabled in bios as well as VM's


DIagnostics and SYS Log Uploaded!


I just need it to work temporarily until i can get hold of a RTX 3080 at a non extortionate rate.

error log VM.PNG

scarif-diagnostics-20210405-2053.zip scarif-syslog-20210405-1948.zip

Edited by Tomway
Link to comment
  • Tomway changed the title to Nvidia GPU Passthrough with vbios - No Display with VM's (System Log and Diagnostics Attached!)
  • 2 weeks later...

Found a fix:


echo 0 > /sys/class/vtconsole/vtcon0/bind
echo 0 > /sys/class/vtconsole/vtcon1/bind
echo efi-framebuffer.0 > /sys/bus/platform/drivers/efi-framebuffer/unbind


Apparently when the system boots, something is getting attached to the GPU memory. These commands clear that off....I think. I don't really know. 


Here are some links for additional reading:




There's a lot more out there as well.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...