Jump to content

[Solved] NVME disk capacity not fully shown - how to format and delete all partitions of a drive?


Recommended Posts

I have a KINGSTON SA2000M8250G NVMe disk that I want to use as a cache (single disk pool). However, after assigning it to the cache it shows a wrong size. The disk has 250GB but unraid reports only 273 MB of it.


I've tried to remove it from the array and re-add it without success. I'm familiar with the console but I'm unfamiliar with the unraid OS so I haven't been able to manually format the drive with tools like parted or fdisk because they are missing and it seems to me that there is no package manager like apt or pkg?


The NVMe previously had few partitions, it was the base installation drive of a Proxmox build, I believe all it needs is a proper formatting and repartition to a single partition (allocating the whole disk).




nvme0n1     259:0    0 232.9G  0 disk
├─nvme0n1p1 259:1    0   260M  0 part /mnt/cache
├─nvme0n1p2 259:2    0 216.6G  0 part
└─nvme0n1p3 259:3    0    16G  0 part






The partition 2 of the nvme was formatted with a zfs_member label which I was able to remove with fdisk. I now have the full 250GB to use.

Edited by maxiride
Link to comment
  • rug changed the title to [Solved] NVME disk capacity not fully shown - how to format and delete all partitions of a drive?

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...