WinServer2019 Vm from Esxi to Unraid


Recommended Posts

Posted (edited)

 

Hello,

I am trying to get a Win Server 2019 VM from an Esxi installation moved to Unraid.

First, I tried to stop the VM on Esxi and copied the vmdk file to the Unraid Server. Using

qemu-img convert -p -f vmdk -O raw <vmdkfile> <vmdkfilename>.img

gives following error “could not open vmdk file, invalid VMDK image descriptor”.

 

Next, I tried to export the VM from Esxi as OVA file but this does not work. It always quits the export.

 

Now I create a full Backup using the Windows server Backup, fine. I created a new Winserver2019 iso including this WindowsImageBackup.

The new Unraid VM starts fine (seabios, 16GB, 100GB HDD) starts fine. On the 2nd setupside I click the repair options, troubleshooting, and Recreate from system image. The Image is found and the wants to format the new hdd. The system image shows the EFI, c:/  and an other partition. When I proceed to format the drive, the system stops with an error message I can not reinstall an EFi system on a BIOS system. Any ideas?

When I create the Unraid VM with OMVF then I end up seeing the BIOS shell.

Thanks for any help

Jann

Edited by Janndr
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.