Jump to content

NGINX reverse proxy / duckdns validation - what am I doing wrong?


Recommended Posts

I had to switch from http validation to duckdns validation because my ISP won't allow forwarding port 80.

I set up mydomain.duckdns.org.

My config screen for Swag is attached.


I set up a few proxy-conf files - for calibre-web, plex, and emby.

An example is attached (for calibre-web).


This does not work. I tried https://calibre.mydomain.duckdns.org and it hangs and times out.

I see that port 443 is forwarding.

Nothing updates in the Swag log when I try to connect, if that's helpful.


I feel like I'm missing something obvious, but I don't see it.

I've tried to add other server_name variables to the calibre-web.subdomain.conf file - like www.calibre.* and calibre.mydomain.* etc. but this doesn't help.


Any advice is appreciated - I've been at it all afternoon.





Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...