Jump to content
We're Hiring! Full Stack Developer ×

Help Required - 10Gb SMB Share no longer working


WirralTom

Recommended Posts

Hi all - really hope someone can help me with this as I'm at my wits end.

 

I've got an Unraid box with a 1Gb connection at 192.168.30.214, which has a network share mapped to my Windows PC at 192.168.30.156. This maps perfectly fine through the usual 'Map a Network Drive'. 

 

Also on my Unraid box is a Mellanox ConnectX-3 CX312A (a 2 port 10Gb card) which is connected via a DAC cable to a Mellanox ConnectX-3 MCX311A (single port card) on the Windows PC. Both of these are mapped to 10.0.0.1 and 10.0.0.3 respectively, and the Unraid share has been mapped as a 10Gb share on the Windows PC

 

This setup has worked perfectly fine for ages, except now its not. The 10.0.0.1 can be pinged from Command Line and receives a response, however when I try to map it as a network drive it now says its unreachable because "The device or resource (10.0.0.1) is not set up to accept connections on port "The File and printer sharing (SMB)". This is bizarre because its accepting SMB connections perfectly fine through the 192.168.30.214 connection. I've been through half a dozen different threads but a lot of them are to do with ensuring SMB in some variation is on in Unraid, which it clearly is in this case. I've tried swapping ports and different DAC cables and no joy, I've tried to Iperf3 between the connections and nothing works there either. 

 

I'm at a complete loose end with it so if anyone has any ideas I'm all ears!!! I've attached the diagnostics. Syslog seems to say at the end that SMB on the 10Gb connection is running but if anyone needs any other information please let me know. 

 

Thanks

 

Tom

 

morpheus-diagnostics-20210921-2029.zip

Edited by WirralTom
wrong diagnostics attached
Link to comment
59 minutes ago, trurl said:
Settings for eth1:
	Link detected: no
--------------------------------
Settings for eth2:
	Link detected: no

 

Sometimes it really does just take another pair of eyes. At some point during swapping the cables back and forth trying to test them I'd left them swapped so eth1 was connected to my backup server which is off, and eth2 was connected to my windows box but I was putting the IP in of eth1 for the connection. Swapped them back and it's all appeared so thank you so much!

 

Quick follow up question, can I give both the 10Gb links the same IP address on Unraid? So can I give them both a 10.0.0.1 address or do I need to name them separately - as for example 10.0.0.1 and 10.0.0.2?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...