Jump to content

Anyone recognize this process? "find /mnt/cache/appdata -noleaf" - (solved)

Go to solution Solved by lurkio,

Recommended Posts

About every 18 seconds two 10-12 second processes kick off, and they cause 25-35% cpu utilization. I have disabled docker, removed plugins, and watched processes, etc. There have been a few red herrings, like file activity viewer that was enabled. So far I see only one culprit that matches the timing but I can't figure out what's triggering it. Anyone recognize this process and know what it's linked to? Thanks all.

ps auxf |grep leaf |grep -v grep  
root      4508  0.0  0.0   2648   792 ?        S    14:46   0:00  |   \_ /bin/timeout 30 find /mnt/disk1/backups -noleaf
root      4510  0.0  0.0   4480  2740 ?        R    14:46   0:00  |       \_ find /mnt/disk1/backups -noleaf
root      4509  0.0  0.0   2648   724 ?        S    14:46   0:00      \_ /bin/timeout 30 find /mnt/cache/appdata -noleaf
root      4511  0.0  0.0   4280  2576 ?        R    14:46   0:00          \_ find /mnt/cache/appdata -noleaf

(I know in this output the cpu is zero, it goes up immediately after, but only one process at a time. I chose this because it shows both processes and what they are "finding" hoping it will give a better clue.)

Edited by lurkio
Link to comment
  • lurkio changed the title to Anyone recognize this process? "find /mnt/cache/appdata -noleaf" - (solved)
  • Solution

Leaving this for posterity. Per the norm, as soon as I actually post this I find the issue. @Squid did in fact on two occasions call out folder caching and fixed similar issue. He was right, I disabled folder caching and the rhythmic usage immediately disappeared. /facepalm

  • Like 2
  • Thanks 3
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...