[Solved] unraid-api: "Value 'false' is not auto/no/yes"


Recommended Posts

Installed the my servers plugin this afternoon, with no issues.  Saw the "My Servers Error, Graphql is offline", and did a quick forum search, which indicated running:

unraid-api restart 

 

was the next thing to do.  It hangs with the "Value 'false' is not auto/no/yes.".  Okay easy enough, with everything computers I apply the reboot method of resolving issues.  However, upon reboot the web GUI will not load.  I'm able to SSH in, and see that nginx never started.  So I start it and get the GUI back.  I tried to change the SSL in the my server setting to "auto" (version 6.9.2) and made sure all plugins were updated.  

 

SSL, was already set to "auto", so change to "no", then back to "auto" to activate the "Apply" button.  Click it, and it basically hangs on the fancy "I'm applying your settings" wave thingy.  I give about 30 minutes, and nothing.  Still waving at me.  Try to run the unraid-api restart again, but it hangs at the same point.  

 

I feel I am certainly missing something, but it is late and I'm lost. 

 

Attached are some diagnostics from my reboot (I believe) when I had to manually start nginx.  I have also restarted the system again, and attaching the current state of diagnositics (had to manually start nginx as well).  

 

If I boot into safe mode, can I remove the my servers plugin even though all plugins are disabled?  Or is there a config file I can edit via SSH/CLI to change the "false" to "no" that unraid-api is looking for?  

 

Thanks! 

tower-diagnostics-20211123-2240.zip tower-diagnostics-20211123-2317.zip

Link to comment
  • guy2545 changed the title to [Solved] unraid-api: "Value 'false' is not auto/no/yes"