Radarr Error: "Failed to create CoreCLR, HRESULT: 0x80004005"

Recommended Posts


Ive been chasing this error in radarr and lidarr for a while. It started a few months ago, around september, after an update. If I run a version from last summer it works. On anything newer it starts showing this error in the logs after a couple days and refuses to start. If I delete radarr and delete its appdata, reinstall, it will work for a couple days then the error happens again. Ive asked the linuxserver guys and they have no clue. I thought that maybe I screwed up my unraid installation somehow, so I installed radarr on another machine that has unraid and completely wiped my main server to start fresh. Today I was gonna start reinstalling all my dockers on my main unraid. Went to open up radarr on the 2nd machine to take a backup to move to 1st machine. Webui wouldnt open so I open the logs and it shows the error again. Failed to create CoreCLR, HRESULT: 0x80004005. So thats 2 different unraids, 2 different machines. The 2nd machine has hardly anything on it and I just set it up recently, so its basically fresh.

This is really irritating and Ive reinstalled radarr many, many times trying to figure out why it keeps doing this. Like I said, I asked in the Linuxserver forum and they dont have any idea. It looks to be a Dotnet issue, something to do with dotnet not being able to access a temp filesystem or something. This error can happen with anything that uses dotnet I guess.

I am going to try the Linuxserver Alpine tag just to see what happens. I find it odd that this would happen on 2 different machines, but that its not a common widespread issue with unraid. That seems really odd to me. Im wondering if there may be some dependency Im missing or something, but I thought dockers were self contained and had everything they needed wrapped up?

I really want to figure this out. It worked fine for 2 years and thenrandomly started in september after an update to Radarr. It happens with all the repositories, Linuxserver, Binhex, Hotio. Ive tried unraid version 6.9.0, 6.9.2, 6.10-rc2. I will also ask the Radarr team and see what they say, but if we can eliminate some issue with my unraid setup that works too. Like I said, its weird that it has happened on 2 unraid installs but its not all over the forums with people having this problem.

I am putting this in general support intentionally because its happened across multiple unraid versions and 2 machines but I cant find anyone else using unraid that has the same issue so Im trying to figure out if Im doing something wrong in unraid that is making this happen, and I asked the linuxserver guys and they dont know. I really, really dont want to have to run radarr in windows. Ive also ran a memory test for over 24 hours without getting any errors. Thought that may be good to mention. Like I said, Ive been chasing this gremlin for a while.


Link to comment

Hi there,


Unfortunately we at Lime Tech cannot help diagnose or troubleshoot application-specific issues like this.  The problem is likely in how the application is built or some combination of that with your hardware.  This is going to be an elusive problem to figure out and it would most likely take a combined effort of the folks maintaining the app as well as the actual creators of the app themselves (that is not LinuxServer.io).  Unfortunately this isn't something we at LT can help with as it is application and user specific.  If this was a wider-spread issue that could easily be recreated by multiple users, then perhaps something is wrong at the OS layer that we could address, but given that you're the only person with this issue right now and we can't reproduce it, this is outside of our wheelhouse.


My suggestion would be to hop on github (or wherever the Radarr project is hosted) and ask the actual developers themselves for assistance.  Be sure to include the errors and any logs/diagnostics so they can chase it down.


All the best,



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.