Nginx Proxy Manager and 502 Bad Gateway


Recommended Posts

Hello together!
Yesterday I installed Nginx Proxy Manager on my Unraid and so far redirects work on Ips that are not the same as the server itself. But as soon as I want to use a bridge Ip I get the error "502 Bad Gateway".
The thousands of solutions like restarting or similar did not help me. 
Also with mobile data the same error occurs.

Do you have any suggestions?

Edited by Boen
Link to comment
  • Boen changed the title to Nginx Proxy Manager and 502 Bad Gateway
  • 4 months later...

Hi There,

I see that this post has been up for a few months and you haven't got a reply yet. Hopefully you managed to resolve your issue. I ran into the same issue myself and found a solution so I thought I'd better post it here:

In my case, the issue was that the NGINX Proxy Manager docker defaults to being on the custom br0 network, while all my other docker containers (which I'm trying setup reverse proxies to) are on the bridge network. Switching those other docker containers to the br0 network as well, OR changing the Settings->Docker->"Host access to custom networks" setting to "Enabled" resolved the issue for me.

In the end I went with switching those Docker containers to the same custom network as that seemed the more secure of the two options.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.