Updated to 6.10 - Typing in unRAID's IP address in a Browser isn't Redirecting the website.

Go to solution Solved by archedraft,

Recommended Posts

Updated to 6.10 today from 6.9 - When I first typed the servers IP address it told me it was not secured. In 6.9 it used to redirect the IP to the long string of numbers and letters followed by .unraid.net. 


I saw that the new cert added wildcards so I updated my cert and then changed my pfSense DNS resolver from unraid.net to myunraid.net
private-domain: "myunraid.net" 


If I click on the Certificate subject blue link under Management Access I can log into unRAID through that address and it is secure. If I type in my ip address it doesn't redirect me though. 

Is that no longer an option or is there another setting I am missing?

Link to comment
  • Solution

Reading the documentation is helpful :)



Manual/Security - Unraid | Docs



When accessing http://[ipaddress] or http://[servername].[localTLD] , the behavior will change depending on the value of the Use SSL/TLS setting:


If Use SSL/TLS is set to Strict, you will be redirected to https://[lan-ip].[hash].myunraid.net However, this behavior makes it more difficult to access your server when DNS is unavailable (i.e. your Internet goes down). If that happens see the note under Https with Unraid.net certificate - with no fallback URL


If Use SSL/TLS is set to Yes, you will be redirected to https://[ipaddress] or https://[servername].[localTLD] as that will likely work even if your Internet goes down.


If Use SSL/TLS is set to No, then the http url will load directly.

Note: for the redirects to work, you must start from http urls not https urls.

Edited by archedraft
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.