Wireguard connected smartphone has no access to home network devices when Docker custom network br0 macvlan is enabled


Recommended Posts

Hi,

 

I am trying to connect with my smartphone to my unraid. 

Issue is that if I enabled the br0 macvlan in docker (custom ip used in for my pihole docker), my via wireguard connected phone is not able to connect to my router at 192.168.189.1 anymore. I can only access the dockers that are part of the br0 network and my unraid machine.

If docker is turned off, everything is working fine. 

 

image.thumb.png.f5561ff0376c6574318498f4253df314.png

 

Once I add the custom br0 network in docker settings, the following routing entries seem to get added:

image.thumb.png.ebae14161736f3cd4390822c1e7fd825.png

 

Any ideas what is causing this behaviour and how to fix it?

 

 

Edit:

I can add a new custom route to my router 192.168.189.1 via br0 which seems to overwrite and allows access of my router via Wireguard, but I am not planning to do this for devices on my network:

image.thumb.png.f0397024eb01f43f6a91ba814b20550e.png

Edited by dweb
Link to comment

I figured out that the shim-br0 routes will be created once I enable the Docker settings "Host access to custom networks".

 

Disabling this setting unfortunately disables the access from the host to the custom network dockers, but at least all other machines will be accessible via wireguard. 

 

I keep the setting disabled until I find a better way. 

 

 

image.thumb.png.f26bafa35016ae15552d76f5c77b8e02.png

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.