"SOLVED" How to disable The PC Speaker

Recommended Posts

Hi,  I have looked everywhere for this with no success, tried to change the "rc.local_shutdown" script to remove the "beep -r 2" in the "rc.d" directory but it didn't work as it gets overwritten after the server is restarted .
My server has a HUANANZHI X99-QD4 with 32GB Ram and an Intel® Xeon® CPU E5-2666 v3 @ 2.90GHz, it has a PC speaker that beeps once when you start and twice when you turn off the server.
I've also tried disabling the first beep from Unraid by adding "pcspkr.conf" to "modprobe.d" and same thing, it's removed after reboot, I know you can solder off the PC speaker, but I wanted to fix it without removing it.
In the bios I can't find how to disconnect the speaker either.
I would be very grateful if someone here could help me with this, thanks in advance

*Solved this with a new bios from GITHUB user Koshak1013.

Edited by serch826
Link to comment
  • serch826 changed the title to "SOLVED" How to disable The PC Speaker
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.