Can't add drive to Array, can't run SMART


Recommended Posts

hi I had a drive that failed a SMART test with the error "A mandatory SMART command failed: exiting. To continue, add one or more '-T permissive' options."  From looking online I believe that this is due to the disk spinning down while the test was running.  I've set the discs to never spin down now, but I can't get the drive working.

 

I tried removing it from the array so it now shows up as "dev1", but when I try to run an extended SMART test the button goes from "start" to "stop" then immediately back to "start".  The quick-test button is greyed out, but no test is running.

 

If I stop the array to try and add it back in I can select it from the drop down list, unraid thinks for a second then the drive disappears.  It's not listed in the array or in the unassigned items.  I have to reboot the server to get it back as "dev1", but still can't do anything.

 

I've tried rebooting several times and did a shut down (didn't unplug, I started it again from WOL as my server is not easily accessible), but this has made no difference.  I don't think the drive itself is defective, how can I add it back to the array please?

ST8000VN004-2M2101_WSD929PK-20221124-1742.txt tower-diagnostics-20221124-1947.zip drive logs.txt

Edited by Agrue
typo
Link to comment
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.