Unraid 6.11.5 Docker Service failed to start.


Go to solution Solved by JorgeB,

Recommended Posts

I was running Unraid 6.11.1 and my Docker Service wouldn't start, with the quoted error.

I upgraded to 6.11.5 and it started (some containers but not most).

I disabled and re-enabled the Docker service and now the service refuses to start again (with the same quoted error).

Quote

Warning: stream_socket_client(): unable to connect to unix:///var/run/docker.sock (No such file or directory) in /usr/local/emhttp/plugins/dynamix.docker.manager/include/DockerClient.php on line 712
Couldn't create socket: [2] No such file or directory
Warning: Invalid argument supplied for foreach() in /usr/local/emhttp/plugins/dynamix.docker.manager/include/DockerClient.php on line 898

I have tried recreating the docker image file, to no effect.

Please help.

You'll find my diagnostics attached.

aperturescience-diagnostics-20230120-0809.zip

Link to comment

Will do. My new RAM arrives Wednesday.

Out of curiosity, I had the CPU overclocked by 8%. I don't know if that overclocked the RAM as well. Could that have led to the RAM failure?

I had pretty high-end RAM (G.Skill Ripjaws V Series) and it was only about a year old.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.