Jump to content

[SOLVED] Read-only file system error?

Recommended Posts

I've been slowly getting up to speed with unRAID.  My recent addition is adding sleep/wake support.  I found the topic in the How To section of the wiki.  While going through the tutorial, I wanted to copy my s3.sh file to /boot/custom/bin.  I went to the /boot directory and did:


mkdir custom


which seemed to work.  Then I did:


cd custom

mkdir bin


and got an I/O error.  I then started noticing issues with my config dir (it was empty) and decided to reboot (shutdown -r now).  Upon reboot, things looked better, but now I can't write to the flash drive at all.


What did I screw up?  Am I not supposed to edit the /boot directory while the array is active? I've attached my syslog to this post.  It's pretty clear in the syslog that it's unhappy with my file system.  I just can't tell why.



Link to comment

Thanks for the help.  I ran chkdsk from the Properties->Tools->Check Now button in Windows 7.  I turned on both check boxes and ran it.  It definitely found some issues and fixed them.


When I put the flash drive back in the unRAID box, it booted fine. However, I noticed some issues in the unmenu screens.  So, I ran unmenu_install -u and rebooted again.  This time it looked good.


Thanks again for the help.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...