Jump to content

(SOLVED) I have a conundrum.


Recommended Posts

My array:

disk0 - 2.0TB WD Green - parity

disk1 - 1.5TB WD Green

disk2 - 2.0TB WD Green

disk3 - 640GB WD Caviar Blue

 

My problem:

Copy test file, disk1 -> pc: ~360Mbps

Copy test file, disk2 -> pc: ~360Mbps

Copy test file, disk3 -> pc: ~120Mbps

 

My 1st thought: the Blue is FUBAR. However, using hdparm -t /dev/sd?:

/dev/sda:

Timing buffered disk reads:  318 MB in  3.01 seconds = 105.76 MB/sec

/dev/sdb:

Timing buffered disk reads:  296 MB in  3.01 seconds =  98.24 MB/sec

/dev/sdc:

Timing buffered disk reads:  344 MB in  3.01 seconds = 114.32 MB/sec

/dev/sdd:

Timing buffered disk reads:  328 MB in  3.01 seconds = 109.12 MB/sec

 

I am just so confused! I tried copying files off the array from 2 different machines and the same story repeats itself.  ??? My other HW is in the sig.

Link to comment

Great. What I am about to say will probably make no sense but if someone understands it please enlighten me.

 

I use disk3 for Transmission. Copying files from unRAID that were created by it results in incredibly slow speeds. If I for example copy a downloaded 4GB file from disk3 it transfers at about 10MB/s. If I copy that file to disk1 or disk 2 and copy it from there to PC it transfers at about 50MB/s. If I copy that file to disk3 again (creating a duplicate) then it transfers to PC at about 55MB/s.  ??? ??? ??? ??? ??? ??? ??? ??? ??? ??? ??? ???

Link to comment

When I was doing those tests Transmission was unloaded. Nothing was copying from or to the server. Which is why is find it so confusing.

 

P.S.

Oh for the love of sweet zombie Jesus. Transmission was the culprit. After setting file preallocation option to 2 (= full preallocation, default is 1 which is partial preallocation - this is what I was using so far), newly downloaded files to disk3 now transfer at ~400Mbps from disk3 to PC. Finally I can enjoy the awesomeness of unRAID again.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...