Jump to content

Strange boot error with Supermicro AOC-SASLP-MV8


Recommended Posts

I have a freshly built unRAID server that has been running flawlessly for a couple of weeks. Up to now I have installed 1 parity + 4 2TB data drives and copied @ 7TB of data from various external and NAS drives. So I am about out of space and preparing for an expansion.

 

I have only 1 motherboard SATA port left so I bought and tried to install a Supermicro AOC-SASLP-MV8 Rev 1.01. The motherboard is an Asus M4A89GTD PRO/USB3. I now get the following error during boot:

 

"Insufficient Runtime space for MPS data! System may operate in PIC or Non-MPS mode. Press F1 to resume."

 

The computer is frozen and F1 does not help. I initially had this card in a PCIe x16 slot but have moved it to a x4 slot with the same error.

 

Searching for this error turned up an instance where putting the mobo SATA ports in ATA mode eliminated the error but obviously I need to run these in AHCI mode.

 

I also found this description of the error in an AMI BIOS manual:

 

"This message is displayed when there is not enough space in the 0F000h runtime area for creating MPS table."

 

I looked in the Marvell bios settings for the AOC and tried Int13 both enabled and disabled with no change. I didn't see anything else in there that looked promising.

 

Any of the gurus here know if that "0F000h runtime area" an IO address or memory location that could be in conflict with some mainboard BIOS setting? Any other clues what I can do to make this card play well in my machine ?

 

TIA

Link to comment

Go through your MB BIOS and disable unused hardware, like sound chips, serial ports, reduce memory aperture for video, etc. Anything not critical that sounds like it might load into your upper memory space.

 

I had a similar problem with a server MB that would not play nice with my 2 controllers. I went to another MB and was able to get both to load.

 

Good luck!

Link to comment

Thanks for your suggestions. Disabled onboard audio & serial port. Couldn't find a setting for video memory. No joy - same boot error. So I decided to disable the onboard SATA and connect my drives to the AOC. This time it boots but the Marvel BIOS reports no drives found !

 

Control-M into the AOC BIOS and tried both INT13 enabled/disabled, no difference. There are four drives connected to channels 0-3 and one on channel 4. They are spread across two cables but the card can't see any of them  ???

 

This is a brand new card with two of these forward breakout cables http://www.cablematters.com/search.aspx?PageSize=10&PageNum=1&SearchTerm=104001.

 

Correct cables ? I guess I could have two that are defective or a deective AOC. Or is it likely still an incompatibility with my mainboard and the AOC ? Without extra parts I don't really have a lot of test options but I will try to test the card in another PC.

Link to comment

Tried the card in another PC - Intel 478 Biostar motherboard. No boot issues with the onboard SATA II controller but the Supermicro still can't see any drives. I tried all SATA headers on both cables, INT13 disabled/enabled with no luck. So I am going to assume that the forward breakout cables from Cable Matters are defective.

 

I am going to check Asus for any BIOS updates on the unRAID server's board and see and if I can open a support ticket with them on the apparent incompatibility issue.

Link to comment

Try the hdds on the supermicro card with the Bios set to IDE mode. If it works then it's not the supermicro card.

 

What version is the firmware on the supermicro card and the BIOS version on the motherboard.

 

Try updating the BIOS, I think from memory some one got it working on the 2001 Bios with the latest firmware on the supermicro card but it didn't work for me on the latestest BIOS (I think 2100 or something)

 

If not search for the post with the motherboard and my name. I've posted a solution. There isn't enough option ROM on the motherboard so firmware 0.15 will work on the supermicro card.

 

http://lime-technology.com/forum/index.php?topic=9488.msg91984#msg91984

 

There are a few more threads that I've posted in that will help.

Josh

Link to comment

Joshpond,

 

Thanks for the links ! I did some searches but did not turn those up. My mobo came with 2101, I updated it to 2201 (most recent) but had the failure on both. The 2001 BIOS doesn't appear to be any smaller and is dated 4/2011 so I assume is more recent than what came on your board based on the dates of the threads linked. No luck with it either.

 

My MV-8 has 3.1.0.21. I looked at Supermicro's site and could not find any downloads for the MV8. I sent them an email but if you could provide the BIOS file I would greatly appreciate it. Shoot me a PM if so.

 

Thanks again, hopefully I am on the road to a solution...

Link to comment

Rajahal,

 

Pretty new to the whole SAS breakout cable thing. First I have heard of a reverse breakout cable. I am guessing that would be used to attach a controller with individual SATA connectors to a backplane with mini-SAS ? Can't quite figure out why it would need to be different. Data flows both directions in either case - reads need different connectivity than writes ?

 

I have reported my problems to Cable Matters. Guess I'll see how good their customer service is.

Link to comment

The reverse breakout cable is intended to connect a miniSAS backplane (such as those in the Norco 4220 and 4224) to regular SATA ports on a motherboard or SATA controller card.  The forward breakout cable does just the opposite - it is intended to connect a miniSAS controller card (such as the SASLP) to regular SATA ports on hard drives or SATA backplanes (such as those in the Norco 4020).  The two cables look identical but are electrically different.  The only way to tell them apart is by the model number.  The forward breakout cables will generally have an 'f' in the model number, while the reverse breakout cables will generally have an 'r' in the model number.

 

I have no idea why they are electrically different, I just know that is the case.  I hope Cable Matters can clear it up for you.

Link to comment

I think one of these two. It'll go through the problems and with someone who got the 2001 Bios working with 0.21 but he may be running the SAS2LP BIOS on the supermicro card.

 

http://lime-technology.com/forum/index.php?topic=8560.0

http://lime-technology.com/forum/index.php?topic=9488.0

 

Quick jump to the answer post

http://lime-technology.com/forum/index.php?topic=9488.msg91984#msg91984

 

Josh

Link to comment

Thanks for those links. I am pretty sure I have the MV8 firmware update process covered. I just can't get the .15 firmware file. Email to Supermicro has not been answered. I found an FTP site but it only has the current .21 file  :-[ Maybe I will have to call them.

 

You mentioned someone might be running the SASLP2 firmware on an SASLP ? Any links to success with that ? I haven't read anything about that in any of the threads I have read.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...