Jump to content

slow parity help please


Recommended Posts

my parity seems to be running really slow

 

Total size: 2 TB

Current position: 725.39 GB (36%)

Estimated speed: 21.01 MB/sec

Estimated finish: 1011 minutes

 

 

That's faster than mine on my older server.  It gets about 16MB/s. 

 

To know your parity calc speed it is correct for YOUR HARDWARE we need to know YOUR HARDWARE and you must follow the general instructions in the sticky at the top of this forum.  (attach a syslog)

 

Joe L.

Link to comment

syslog is attached

You have 20 drives... Are any on a PCI bus?  You've not described your hardware.  (Motherboard, disk controller cards)

 

Your speed is looking pretty normal if you do not have optimal hardware with the required buss bandwidth.

 

 

Link to comment

Aug  8 20:04:37 Tower kernel: Probing IDE interface ide1...
Aug  8 20:04:37 Tower kernel: ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Aug  8 20:04:37 Tower kernel: ata5: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Aug  8 20:04:37 Tower kernel: ata3: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Aug  8 20:04:37 Tower kernel: ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)

 

It seems as though your 4 drives on the motherboard might be running at IDE speeds.  Boot into your motherboard's BIOS and set all SATA ports to AHCI mode.  Also disable IDE/SATA combined mode if you see it anywhere.

 

In the SASLP cards' BIOS, make sure INT13 is disabled for both cards.

 

You also have some WDEARS drives.  Are these drives 4k aligned or not?  Do they have jumpers installed?

Link to comment

Could this have anything to do with the parity Check Speed issues Tom mentioned he found in the 2.6.39.1 kernel back in the beta.7 days? I know beta10 is using 2.6.39.3, but it may be related...

 

The linux kernel was also updated to 2.6.37.6 in order to pick up some mvsas driver fixes.  (I wanted to update to the latest kernel release, 2.6.39.1, but parity check speed was cut by 80% using this kernel for some reason that I haven't figured out yet.)

 

 

Link to comment

Aug  8 20:04:37 Tower kernel: Probing IDE interface ide1...
Aug  8 20:04:37 Tower kernel: ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Aug  8 20:04:37 Tower kernel: ata5: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Aug  8 20:04:37 Tower kernel: ata3: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Aug  8 20:04:37 Tower kernel: ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)

 

It seems as though your 4 drives on the motherboard might be running at IDE speeds.  Boot into your motherboard's BIOS and set all SATA ports to AHCI mode.  Also disable IDE/SATA combined mode if you see it anywhere.

 

In the SASLP cards' BIOS, make sure INT13 is disabled for both cards.

 

You also have some WDEARS drives.  Are these drives 4k aligned or not?  Do they have jumpers installed?

 

 

 

all drives are set pm ahci in bios

on the sata cards int13 disabled on both

all drves are 4k aligned with no jumpers

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...