Jump to content

AMD GPU Passtrough

Recommended Posts



I've build a new unraid server that also should run Adobe Media encoder inside a windows 10 VM as a rendering node in the studio. I'm really struggling with getting my AMD RX6650XT to work as a GPU Passtrough device in my VM.


I've spend hours of digging and trying to troubleshoot and i did came a bit closed but do need help for the last leg.


My setup:

Intel i5 13500


Things i have done:

- Set the intergrated graphics as primary gpu inside the BIOS

- Added into the Flash UNRAID OS dialog

append vfio-pci.ids=1002:73ef,1002:ab28 video=efifb:off initrd=/bzroot,/bzroot-gui

- in System devices i binded IOMMU group 14 AMD Navi & 15 AMD Navi audio divice. to vfio at boot

- Changed the VM XLM to have a multifucntion device for the Video and Audio part of the GPU

- Use GPU-Z on another machine to extract the Vbios from the card and used inside the VM Config.

- Tried booting with or without screens connected to intergrated GPU and Pastrough GPU. (i want to eventuelly run headless)


Running the VM with VNC works fine. But with the GPU as video device it does not. I've installed Teamviewer on the VM and when running with GPU as video device it shows a black screen.


My guess it that is has something to do with the fact that while booting is do see the Unraid prompt (the one where you can choose  Unraid os, GUImode, Memtest etc) on the GPU output. On the intergreted GPU it will eventually boot into unraid but the GPU passtrough screen goes freezed at Loading /bzroot-gui...ok


I did get at somepoint my output to work on the passtrough GPU but in device manager the GPU was not detected. it only showed the generic windows display.


Any help?


Atteched you find my diagnosctics file and VM XML



detochtnas-diagnostics-20230526-1145.zip VM.xml

Link to comment

Cant let this go. 


I've now:

- tried binding the IOMMU groups to VFIO and not binding it. Since its not grouped with outher devices

- Added a second VM with SeaBios as bios. No difference.

- When binding the IOMMU groups the System device logs says it succesfully passed the GPU and soundcard to VFIO

- I've tried a Nvidea card (without vbios). With this i got a bit more luck. When starting the VM the Graphics card did switch to a black screen instead of hanging on the boot selection mode window. This may be fixed with a correct vbios.


Could it be the vBios of the AMD card?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...